This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031679 - openstack-nova requires python-cinderclient
openstack-nova requires python-cinderclient
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Havana
Assigned To: Xavier Queralt
Gabriel Szasz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 09:30 EST by Lars Kellogg-Stedman
Modified: 2014-06-18 03:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-5.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-24 03:45:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2013-11-18 09:30:08 EST
Description of problem:

After installing openstack-nova-common-2013.2-2.el6, running "nova-manage service list" yields:

Command failed, please check log for more info
2013-11-18 09:27:21.556 4898 CRITICAL nova [-] No module named cinderclient
2013-11-18 09:27:21.556 4898 TRACE nova Traceback (most recent call last):
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/bin/nova-manage", line 10, in <module>
2013-11-18 09:27:21.556 4898 TRACE nova     sys.exit(main())
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/cmd/manage.py", line 1377, in main
2013-11-18 09:27:21.556 4898 TRACE nova     ret = fn(*fn_args, **fn_kwargs)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/cmd/manage.py", line 685, in list
2013-11-18 09:27:21.556 4898 TRACE nova     servicegroup_api = servicegroup.API()
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/servicegroup/api.py", line 70, in __new__
2013-11-18 09:27:21.556 4898 TRACE nova     *args, **kwargs)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/importutils.py", line 40, in import_object
2013-11-18 09:27:21.556 4898 TRACE nova     return import_class(import_str)(*args, **kwargs)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/servicegroup/drivers/db.py", line 37, in __init__
2013-11-18 09:27:21.556 4898 TRACE nova     self.conductor_api = conductor.API(use_local=self.db_allowed)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/conductor/__init__.py", line 26, in API
2013-11-18 09:27:21.556 4898 TRACE nova     return api(*args, **kwargs)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/conductor/api.py", line 57, in __init__
2013-11-18 09:27:21.556 4898 TRACE nova     self._manager = utils.ExceptionHelper(manager.ConductorManager())
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/conductor/manager.py", line 83, in __init__
2013-11-18 09:27:21.556 4898 TRACE nova     openstack_driver.get_openstack_security_group_driver())
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/network/security_group/openstack_driver.py", line 43, in get_openstack_security_group_driver
2013-11-18 09:27:21.556 4898 TRACE nova     return importutils.import_object(NEUTRON_DRIVER)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/importutils.py", line 40, in import_object
2013-11-18 09:27:21.556 4898 TRACE nova     return import_class(import_str)(*args, **kwargs)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/importutils.py", line 30, in import_class
2013-11-18 09:27:21.556 4898 TRACE nova     __import__(mod_str)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/api/openstack/compute/__init__.py", line 35, in <module>
2013-11-18 09:27:21.556 4898 TRACE nova     from nova.api.openstack.compute import servers
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/api/openstack/compute/servers.py", line 53, in <module>
2013-11-18 09:27:21.556 4898 TRACE nova     CONF.import_opt('reclaim_instance_interval', 'nova.compute.manager')
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/oslo/config/cfg.py", line 1796, in import_opt
2013-11-18 09:27:21.556 4898 TRACE nova     __import__(module_str)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/compute/manager.py", line 85, in <module>
2013-11-18 09:27:21.556 4898 TRACE nova     from nova.volume import encryptors
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/volume/encryptors/__init__.py", line 52, in <module>
2013-11-18 09:27:21.556 4898 TRACE nova     _volume_api = volume.API()
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/volume/__init__.py", line 38, in API
2013-11-18 09:27:21.556 4898 TRACE nova     cls = importutils.import_class(volume_api_class)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/openstack/common/importutils.py", line 30, in import_class
2013-11-18 09:27:21.556 4898 TRACE nova     __import__(mod_str)
2013-11-18 09:27:21.556 4898 TRACE nova   File "/usr/lib/python2.6/site-packages/nova/volume/cinder.py", line 26, in <module>
2013-11-18 09:27:21.556 4898 TRACE nova     from cinderclient import exceptions as cinder_exception
2013-11-18 09:27:21.556 4898 TRACE nova ImportError: No module named cinderclient
2013-11-18 09:27:21.556 4898 TRACE nova 

It looks like openstack-nova should Require: python-cinderclient.
Comment 1 Xavier Queralt 2013-11-18 09:54:48 EST
This dependency was mistakenly added when the encrypted volumes feature was added and has been fixed upstream (https://review.openstack.org/#/c/54533/), I'll backport the patch to RDO.

Note You need to log in before you can comment on or make changes to this bug.