This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031689 - [RFE] Migrate Glance notifier to oslo.messaging
[RFE] Migrate Glance notifier to oslo.messaging
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity unspecified
: Upstream M3
: 5.0 (RHEL 7)
Assigned To: Flavio Percoco
Dafna Ron
: FutureFeature, Triaged
: 1041742 (view as bug list)
Depends On:
Blocks: 1030067
  Show dependency treegraph
 
Reported: 2013-11-18 09:46 EST by Flavio Percoco
Modified: 2016-04-26 10:58 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-glance-2014.1-2.el7ost
Doc Type: Enhancement
Doc Text:
Previously, as per most other OpenStack projects, Glance used to rely on an RPC library coming from oslo-incubator. This library graduated from the incubator and was moved into its own project, oslo.messaging. This request for enhancement tracks Glance's adoption of oslo.messaging. Although the messaging library maintains backwards compatibility with older configuration options, upgrading the configuration files to use the `transport_url` and the new RPC options as necessary is highly recommended. The older configuration options are likely to be removed in future versions of the project.
Story Points: ---
Clone Of:
: 1066035 (view as bug list)
Environment:
Last Closed: 2014-07-08 11:31:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 57678 None None None Never

  None (edit)
Description Flavio Percoco 2013-11-18 09:46:39 EST
This is a tracking bug for the work happening here: https://blueprints.launchpad.net/glance/+spec/oslo-messaging
Comment 2 Flavio Percoco 2013-12-04 10:03:11 EST
The patch landed upstream and will be part of the I-1 cut.
Comment 3 Sean Cohen 2014-03-19 03:50:19 EDT
*** Bug 1041742 has been marked as a duplicate of this bug. ***
Comment 7 Tzach Shefi 2014-06-15 07:28:29 EDT
Verified on: 
RHEL7

python-glance-2014.1-2.el7ost.noarch
python-glanceclient-0.12.0-1.el7ost.noarch
openstack-glance-2014.1-2.el7ost.noarch

Passed Glance basic sanity testing.
Comment 10 errata-xmlrpc 2014-07-08 11:31:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0851.html

Note You need to log in before you can comment on or make changes to this bug.