Bug 1031714 - unable to create thin pool with thinLvm driver
unable to create thin pool with thinLvm driver
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
x86_64 Linux
unspecified Severity urgent
: ---
: 4.0
Assigned To: Jon Bernard
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 10:23 EST by Haim
Modified: 2016-04-26 11:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 09:32:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2013-11-18 10:23:24 EST
Description of problem:

setup:

- [bare metal] controller (running all services)
- [VM] glance located on remote machine 
- [VM] cinder located on remote machine

flow:

- cinder create --display-name test 1

error:

2013-11-18 16:50:08.199 30660 ERROR cinder.volume.manager [req-84db519a-d153-4cc3-9e94-1a660ec0bd12 None None] Error encountered during initialization 
of driver: LVMISCSIDriver
2013-11-18 16:50:08.204 30660 ERROR cinder.volume.manager [req-84db519a-d153-4cc3-9e94-1a660ec0bd12 None None] Unexpected error while running command.
Command: sudo cinder-rootwrap /etc/cinder/rootwrap.conf lvcreate -T -L 20 cinder-volumes/cinder-volumes-pool
Exit code: 5
Stdout: ''
Stderr: '  Thin pool cinder-volumes-pool already exists in Volume group cinder-volumes.\n'


conf:

[root@hateya-cinder ~]# egrep lvm_type  /etc/cinder/cinder.conf 
lvm_type=thin





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Eric Harney 2013-11-18 10:29:44 EST
I logged into the Cinder node, it was set to lvm_type=default and had no thin pool in the VG.  I set the lvm_type to thin and restarted the volume service and seems to have created the pool successfully.

The log message from before indicates that it thought there was no pool, so tried to create one, but then LVM errored saying it already existed.

After that, cinder create seems to be working as expected.
Comment 2 Eric Harney 2013-11-18 10:51:57 EST
The problem here was pool creation -- the secondary issue about failing to create a volume is bug 1022714.
Comment 6 Haim 2013-12-03 09:32:19 EST
works for me on latest cinder versions:

openstack-cinder-2013.2-2.el6ost.noarch

Note You need to log in before you can comment on or make changes to this bug.