This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1031722 - report from a cluster with no DC - report portal doesn't open and no error message appear
report from a cluster with no DC - report portal doesn't open and no error me...
Status: CLOSED DEFERRED
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
low Severity unspecified (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Alexander Wels
movciari
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 10:40 EST by sefi litmanovich
Modified: 2016-07-22 00:43 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-22 00:43:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description sefi litmanovich 2013-11-18 10:40:33 EST
Description of problem:

when trying to create a report by choosing a cluster that has no DC, double clicking on it and choosing show report: {some report}, nothing happens. the report portal doesn't pop, and no error message is provoked.

Version-Release number of selected component (if applicable):
rhevm is23


Steps to Reproduce:
1. engine-setup.
2. * yum install rhevm-dwh rhevm-reports
* rhevm-dwh-setup
* rhevm-reports-setup
3. create some DCs, clusters etc.
4. force remove one of the DCs leaving one of the clusters without a DC
5. double click on that cluster and choose show report: {some report}.

Actual results:
Nothing happens, the action seems to be ignored completely


Expected results:

2 options:

1. an error message: "cluster is not attached to any DC, cannot show rhevm-report"
2. report portal opens allowing you to produce a report from some existing and working DC
Comment 1 Einav Cohen 2013-11-21 13:28:32 EST
@Yaniv - will/should the cluster reports (available from the web-admin when selecting a cluster) work properly for "orphan" cluster (i.e. clusters that don't belong to any DC)?
Comment 2 Yaniv Lavi (Dary) 2013-11-21 14:39:16 EST
(In reply to Einav Cohen from comment #1)
> @Yaniv - will/should the cluster reports (available from the web-admin when
> selecting a cluster) work properly for "orphan" cluster (i.e. clusters that
> don't belong to any DC)?

Is this a option for a active cluster with hosts and vms?
Comment 3 Einav Cohen 2013-11-21 15:43:16 EST
(In reply to Yaniv Dary from comment #2)
> (In reply to Einav Cohen from comment #1)
> > @Yaniv - will/should the cluster reports (available from the web-admin when
> > selecting a cluster) work properly for "orphan" cluster (i.e. clusters that
> > don't belong to any DC)?
> 
> Is this a option for a active cluster with hosts and vms?

it may have Hosts, not sure. it probably won't have VMs, as VMs need storage domains, and if there is no DC - there are no storage domains.
Comment 4 Yaniv Lavi (Dary) 2013-11-22 04:27:26 EST
(In reply to Einav Cohen from comment #3)
> (In reply to Yaniv Dary from comment #2)
> > (In reply to Einav Cohen from comment #1)
> > > @Yaniv - will/should the cluster reports (available from the web-admin when
> > > selecting a cluster) work properly for "orphan" cluster (i.e. clusters that
> > > don't belong to any DC)?
> > 
> > Is this a option for a active cluster with hosts and vms?
> 
> it may have Hosts, not sure. it probably won't have VMs, as VMs need storage
> domains, and if there is no DC - there are no storage domains.

So there is no point in allowing reporting on it. We should add a pop up to tell the user he must add it to DC to report on it.



Yaniv
Comment 5 Einav Cohen 2013-11-22 10:14:34 EST
(In reply to Yaniv Dary from comment #4)
> 
> So there is no point in allowing reporting on it. We should add a pop up to
> tell the user he must add it to DC to report on it.
> 

you are probably right, and this is probably what we should/will do; but just so I will have all the information / understand the root cause of the problem: As far as you know: As the reports are implemented today: Is it impossible to run them on orphan clusters (e.g. since they require the relevant DC identifier, for example), or is it possible, just not interesting?
Comment 6 Yaniv Lavi (Dary) 2013-11-23 21:35:46 EST
(In reply to Einav Cohen from comment #5)
> (In reply to Yaniv Dary from comment #4)
> > 
> > So there is no point in allowing reporting on it. We should add a pop up to
> > tell the user he must add it to DC to report on it.
> > 
> 
> you are probably right, and this is probably what we should/will do; but
> just so I will have all the information / understand the root cause of the
> problem: As far as you know: As the reports are implemented today: Is it
> impossible to run them on orphan clusters (e.g. since they require the
> relevant DC identifier, for example), or is it possible, just not
> interesting?

There is no way to do this. Since the report need DC and also the right click reporting looks for dc ID and this is way it doesn't work. should not be possible and not interesting to my opinion.


Yaniv
Comment 8 Eli Mesika 2013-11-24 08:44:18 EST
Einav 

Is that a UI BZ ?
Comment 9 Einav Cohen 2013-11-25 14:18:33 EST
(In reply to Eli Mesika from comment #8)
> Einav 
> 
> Is that a UI BZ ?

yes (and indeed the component is set correctly to 'ovirt-engine-webadmin-portal').
Comment 10 Einav Cohen 2015-09-17 09:34:48 EDT
low priority, no capacity - pushing to 4.0 for now.
Comment 11 Red Hat Bugzilla Rules Engine 2015-11-30 15:43:25 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 12 Alexander Wels 2016-07-21 13:08:17 EDT
Can we close this one, since the reports are no longer available in 4.0?

Note You need to log in before you can comment on or make changes to this bug.