Bug 1031742 - fatal error: malformed or corrupted PCH file - builddir in pch file
fatal error: malformed or corrupted PCH file - builddir in pch file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pocl (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Fabian Deutsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 11:36 EST by Orion Poplawski
Modified: 2013-11-19 08:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 08:50:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-11-18 11:36:42 EST
Description of problem:

$ clinfo
Number of platforms                               2
  Platform Name                                   Portable Computing Language
  Platform Vendor                                 The pocl project
  Platform Version                                OpenCL 1.2 pocl 0.9-pre
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd

  Platform Name                                   Intel(R) OpenCL
  Platform Vendor                                 Intel(R) Corporation
  Platform Version                                OpenCL 1.2 LINUX
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_spir cl_intel_exec_by_local_thread cl_khr_fp64 

  Platform Name                                   Portable Computing Language
Number of devices                                 1
  Device Name                                     pthread-Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz
  Device Vendor                                   unknown
  Device Version                                  OpenCL 1.2 pocl
  Driver Version                                  0.9-pre
  Device OpenCL C Version                         OpenCL C 1.2
  Device Type                                     Default
  Device Profile                                  FULL_PROFILE
  Max compute units                               4
  Max clock frequency                             1800MHz
  Device Partition                                (core)
    Max number of sub-devices                     1
    Supported partition types                     none
  Max work item dimensions                        3
    Max work item size[0]                         1024
    Max work item size[1]                         1024
    Max work item size[2]                         1024
  Max work group size                             1024
fatal error: malformed or corrupted PCH file: 'could not find file
      '/builddir/build/BUILD/pocl-8a26561008f9d53c6b023a5f99d3b3ce674aeab7/lib/kernel/x86_64/../../../include/_kernel_c.h' referenced by AST file'
1 error generated.
getWGsizes:134: build program : error -11

$ strings /usr/lib64/pocl/x86_64/_kernel.h.pch | grep builddir
/builddir/build/BUILD/pocl-8a26561008f9d53c6b023a5f99d3b3ce674aeab7/lib/kernel/x86_64/../../../include/_kernel.h
/builddir/build/BUILD/pocl-8a26561008f9d53c6b023a5f99d3b3ce674aeab7/lib/kernel/x86_64
/builddir/build/BUILD/pocl-8a26561008f9d53c6b023a5f99d3b3ce674aeab7/lib/kernel/x86_64/../../../include/_kernel_c.h
/builddir/build/BUILD/pocl-8a26561008f9d53c6b023a5f99d3b3ce674aeab7/lib/kernel/x86_64/../../../include/x86_64/types.h
/builddir/build/BUILD/pocl-8a26561008f9d53c6b023a5f99d3b3ce674aeab7/lib/kernel/x86_64/../../../include/_kernel.h
#include "/builddir/build/BUILD/pocl-8a26561008f9d53c6b023a5f99d3b3ce674aeab7/lib/kernel/x86_64/../../../include/x86_64/types.h"

Version-Release number of selected component (if applicable):
pocl-0.9-0.5.git20131111.8a26561.fc20.x86_64
Comment 1 Fabian Deutsch 2013-11-19 08:50:14 EST
Hey,

this seems to be a bad snapshot. I unpushed the build in updates-testing..
Comment 2 Fabian Deutsch 2013-11-19 08:50:57 EST
Got never released to updates, therefor CURRENTRELEASE.

A new snapshot will be around in the next weeks. Stay tuned.

Note You need to log in before you can comment on or make changes to this bug.