Bug 103176 - words file not utf8 clean
words file not utf8 clean
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: aspell-en-gb (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
http://dictionary.reference.com/searc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 08:12 EDT by David Woodhouse
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 15:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2003-08-27 08:12:37 EDT
Although aspell appears can ignore accents and pretend that words like 'role'
and 'naive' are spelled correctly for the benefit of dim people, it's useful
that it has the option to enable proper spelling, now that the distro is UTF-8
capable.

Well, it _would_ be useful, if 'role' and 'naive' didn't actually appear in
their incorrect ASCII-only forms in the words files. :)

Is this because we've built the files incorrectly, or is the source of the word
lists at fault?
Comment 1 Eido Inoue 2003-10-13 15:14:59 EDT
> Well, it _would_ be useful, if 'role' and 'naive' didn't actually appear in
> their incorrect ASCII-only forms in the words files. :)

"naive" etc, is correct spelling, in the English language. (see the included
URL; note that the non-accented version is listed first, indicated the preferred
spelling) When a foreign word is adopted by another language, it is often
transliterated (and accepted) both in spelling and in pronunciation. An extreme
example would be a Japanese word such as "sushi"; we don't write it in
kanji/kana. A less extreme example would be French like naive; we don't
pronounce "Paris" using the "correct" French pronounciation either.

This bug is thus a feature request to include the accented "variants" of foreign
loanwords.

> Is this because we've built the files incorrectly, or is the source of the word
> lists at fault?

The source of the word lists (for the English dicts) do not include the accented
versions.

Note You need to log in before you can comment on or make changes to this bug.