Bug 1031803 - Bookmarks menu hierarchy fails to hold mouse focus [org.gnome.desktop.wm.preferences.focus-mode=mouse]
Bookmarks menu hierarchy fails to hold mouse focus [org.gnome.desktop.wm.pref...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 14:47 EST by Keith Dixon
Modified: 2015-02-17 14:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 14:17:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Dixon 2013-11-18 14:47:16 EST
Description of problem:

This may not be the responsibility of Firefox but that is the only application with which I have experienced this behaviour.

With org.gnome.desktop.wm.preferences.focus-mode set to 'mouse', if I navigate, with the mouse, through a bookmarks menu hierarchy such as:

Bookmarks->Bookmarks Toolbar->Level1->...->Leveln->Entry

such that some level is rendered outside the boundary of the main Firefox window and over the window of another application then focus shifts to that application and the rendered menu hierarchy disappears so that 'Entry' cannot be selected.

This does not happen if there is no other application window under the rendered menu or when org.gnome.desktop.wm.preferences.focus-mode is set to 'click'.


Version-Release number of selected component (if applicable):
firefox-25.0-3.fc19.x86_64
gnome-shell-3.8.4-2.fc19.x86_64
mutter-3.8.4-1.fc19.x86_64

How reproducible:
Always, given the conditions described above.

Steps to Reproduce:
1.  See Description of Problem
2.
3.

Actual results:


Expected results:
Rendered menu hierarchy should hold the mouse focus outside the boundary of the main window.

Additional info:
Comment 1 Martin Stransky 2014-01-06 09:22:54 EST
Can you reproduce it with a binary from mozilla.com? If so we should move it upstream.
Comment 2 Keith Dixon 2014-01-06 14:16:40 EST
I just tried firefox-26.0.tar.bz2 but I get 

[dixon@computer2 firefox]$ ./firefox&
[1] 3026
[dixon@computer2 firefox]$ XPCOMGlueLoad error for file /home/dixon/firefox/libxul.so:
libXrender.so.1: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

[1]+  Exit 255                ./firefox
[dixon@computer2 firefox]$ 

Any idea what I am missing?
Comment 3 Martin Stransky 2014-01-07 03:29:33 EST
I guess you're running i686 browser on x86_64 system. Try to download a 64-bit browser from ftp://ftp.mozilla.org/pub/firefox/releases/26.0/linux-x86_64/
Comment 4 Keith Dixon 2014-01-07 04:42:14 EST
Duh! I guess I should have worked that out for myself but I presumed their website would deliver me the right version (they have the same filenames!).

Anyway, 
ftp://ftp.mozilla.org/pub/firefox/releases/26.0/linux-x86_64/en-GB/firefox-26.0.tar.bz2 has the same behavior. 
With:
gnome-shell-3.8.4-3.fc19.x86_64
mutter-3.8.4-1.fc19.x86_64
Comment 5 Fedora End Of Life 2015-01-09 15:37:39 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2015-02-17 14:17:43 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.