Bug 1031824 - Evoltion does not start (segmentation fault)
Evoltion does not start (segmentation fault)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: webkitgtk3 (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 16:16 EST by thomas.michel
Modified: 2013-11-25 06:43 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 06:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log as requested (18.05 KB, text/plain)
2013-11-20 14:37 EST, thomas.michel
no flags Details

  None (edit)
Description thomas.michel 2013-11-18 16:16:49 EST
Description of problem:

Trying to evolution results in Segmentation fault in Fedora 20 

Version-Release number of selected component (if applicable):
3.10.2

How reproducible:
run "evolution" from command line

Steps to Reproduce:
1.Run evolution
2. Configure Mail account 
3.evolution crashes 

Actual results:
segfault

Expected results:
Evolution window shown

Additional info:
 
I completely resetet evolution (deleting directories, clearing gconf data). After that, evoltion start with the initial setup screen. When the setup is finished, evolution won't start but segfaults.
Comment 1 Milan Crha 2013-11-20 07:16:31 EST
Thanks for a bug report. Could you provide a backtrace of the crash, please? ABRT may do it for you, but you can do it too, if you install gdb, evoluion-data-server-deubginfo and evolution-debuginfo, as a starter (for debuginfo packages), and then run ecvolution in gdb like this:

   $ gdb evolution --ex r --ex "t a a bt" --ex q
and you grab everything what the gdb will print. Thanks in advance.
Comment 2 thomas.michel 2013-11-20 14:37:52 EST
Created attachment 826813 [details]
Debug log as requested
Comment 3 Milan Crha 2013-11-21 06:18:09 EST
Thanks for the update. I see this is crashing in a webkitgtk3 code, something around plugins. Maybe one of the installed browser plugins is causing the crash. I think a Google+ or GTalk or some such did so in the past, and its uninstall helped.

Could you check content of /usr/lib64/mozilla/plugins (alternatively ../lib/...) and try to move away plugins from there, whether removal of one of them will fix the crash on start, please?
Comment 4 thomas.michel 2013-11-22 15:46:07 EST
(In reply to Milan Crha from comment #3)
> Thanks for the update. I see this is crashing in a webkitgtk3 code,
> something around plugins. Maybe one of the installed browser plugins is
> causing the crash. I think a Google+ or GTalk or some such did so in the
> past, and its uninstall helped.
> 
> Could you check content of /usr/lib64/mozilla/plugins (alternatively
> ../lib/...) and try to move away plugins from there, whether removal of one
> of them will fix the crash on start, please?

Hi Milan,

that did the trick. The problem is caused by mozplugger.so. As soon as I remove that, evolution starts without problem.

Regards,

Tom.
Comment 5 Milan Crha 2013-11-25 06:43:21 EST
Thanks for the update. I see it comes from a mozplugger package, and doesn't provide anything special (I do not have it installed myself). I hope you'll not miss its functionality.

The evolution 3.12.x version (far far away, still unsure whether it'll reach it) may use Webkit2, where this plugin loading might not be done at all. Anyway, I'm happy you made it work again.

Note You need to log in before you can comment on or make changes to this bug.