Bug 1031880 - QMP command query-block-jobs should give a reasonable speed value as default
QMP command query-block-jobs should give a reasonable speed value as default
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Ademar Reis
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 23:07 EST by Jun Li
Modified: 2013-12-10 12:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 12:17:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun Li 2013-11-18 23:07:30 EST
Description of problem:
When do block_stream without specify the speed, use query-block-jobs check the speed is 0. But the real speed is not 0, so maybe qmp should give a reasonable speed value as default(without specify the speed).

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-19.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with following cli.
# /usr/libexec/qemu-kvm -S -M pc-i440fx-rhel7.0.0 -cpu SandyBridge -enable-kvm -m 4G -smp 4,sockets=2,cores=2,threads=1 -name juli -uuid 355a2475-4e03-4cdd-bf7b-5d6a59edaa68 -rtc base=localtime,clock=host,driftfix=slew -device virtio-scsi-pci,bus=pci.0,addr=0x5,id=scsi0 -drive file=/root/sn1,if=none,id=drive-scsi0-0-0,media=disk,cache=none,format=qcow2,werror=stop,rerror=stop,aio=native  -device scsi-hd,drive=drive-scsi0-0-0,bus=scsi0.0,scsi-id=0,lun=0,id=juli,bootindex=0 -drive file=iscsi://10.66.6.82:3260/iqn.2013-11.com.example:storage.disk1.juli.xyz/3,if=none,id=drive-virtio0-0-0,media=disk,werror=stop,rerror=stop,cache=none,format=qcow2 -device virtio-blk-pci,bus=pci.0,drive=drive-virtio0-0-0,id=virtio0-0-0 -drive file=/home/ISO/en_windows_8.1_preview_x86_dvd_2358833.iso,if=none,media=cdrom,format=raw,aio=native,id=drive-ide1-0-0 -device ide-drive,drive=drive-ide1-0-0,id=ide1-0-0,bus=ide.0,unit=0,bootindex=4 -device virtio-balloon-pci,id=ballooning -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -net none -k en-us -boot menu=on,reboot-timeout=-1,strict=on -qmp tcp:0:4477,server,nowait -serial unix:/tmp/ttyS0,server,nowait -vnc :3 -spice port=5939,disable-ticketing  -vga qxl -global qxl-vga.revision=3 -monitor stdio -monitor tcp:0:7777,server,nowait -monitor unix:/tmp/monitor1,server,nowait -netdev tap,id=tap1,vhost=on,queues=4,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,ifname=tap-juli -device virtio-net-pci,netdev=tap1,id=nic1,mq=on,vectors=17,mac=1a:59:0a:4b:aa:94
2.do block_stream without specify speed.
$ telnet 10.66.106.4 4477
{ 'execute' : 'qmp_capabilities' }
{ "execute": "blockdev-snapshot-sync", "arguments": { "device": "drive-scsi0-0-0","snapshot-file":"/root/sn222","format": "qcow2" } }
{ "execute": "block-stream", "arguments": { "device": "drive-scsi0-0-0" } }
3.check the default speed using query-block-jobs via qmp.
{ "execute" : "query-block-jobs", "arguments" : {} }
{"return": [{"io-status": "ok", "device": "drive-scsi0-0-0", "busy": true, "len": 32212254720, "offset": 737673216, "paused": false, "speed": 0, "type": "stream"}]}

Actual results:
{ "execute" : "query-block-jobs", "arguments" : {} }
{"return": [{"io-status": "ok", "device": "drive-scsi0-0-0", "busy": true, "len": 32212254720, "offset": 737673216, "paused": false, "speed": 0, "type": "stream"}]}

Expected results:
As the real speed is not 0, qmp should give a reasonable speed value as default(without specify the speed).

Additional info:
Comment 2 Ademar Reis 2013-12-10 12:17:20 EST
We won't support direct usage of qemu-kvm and/or QMP/HMP in RHEL7. Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.