Bug 1031905 - [fork][online_ui_402]Sign up links on community pages Sign up links on community pages should use relative path.
[fork][online_ui_402]Sign up links on community pages Sign up links on commun...
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jessica Forrester
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 01:11 EST by Yujie Zhang
Modified: 2015-05-14 21:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 09:29:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2013-11-19 01:11:53 EST
Description of problem:

Checked the sign up links on community page, they all point to https://openshift.redhat.com/app/account/new page. They should point to the new sign up page https://<server>:8118/app/account/new page. Links are as following:
"Sign Up Online" link on /products page
"SIGN UP FOR FREE" link on /products/online page
"Try OpenShift Online" link on http://openshift.github.io/ page
"Sign UP for silver" and "Sign up for free" links on /products/pricing page
Checked the source code of above links, found that they are all using hard code like the following:
<a href="https://openshift.redhat.com/app/account/new">Sign Up Online</a>
Changed the code to be relative path "/app/account/new", and it worked.

Version-Release number of selected component (if applicable):
fork_ami_online_ui_402_940

How reproducible:
always

Steps to Reproduce:
1.After running /etc/drupal6/enable-sso.sh , the configuration in console-devenv.conf file is as following:
DEFAULT_URL_OPTIONS_HOST=ec2-54-224-148-85.compute-1.amazonaws.com
DEFAULT_URL_OPTIONS_PORT=
ASSET_HOST=https://ec2-54-224-148-85.compute-1.amazonaws.com
USE_COMMUNITY_NEW_ACCOUNT_URL=true
STREAMLINE_ENABLED=true
2.cd into /usr/share/drupal6 and then run "drush cc all"
3.Check the sign up links on the community pages

Actual results:

Sign up link on the community pages always point to old sign up link

Expected results:

Sign up links on the community page should use relative path "/app/account/new",so it can redirect to new sign up links https://<server>:8118/app/account/new

Additional info:
Comment 1 Jessica Forrester 2013-11-19 19:05:58 EST
Run this:

ruby ./root/.source_build/li/drupal/drupal6-openshift-redhat_sso/migrate-content-2-0-37.rb

And this will migrate all the account creation links that are in community content (pages, comments, etc) from openshift.redhat.com/app/account/new to www.openshift.com/app/account/new

The only cases where the links will be relative in the community (the only ones controlled by the config parameter) are where it is generated from code, one example of this is the Sign Up button in the top right.  As long as this link is properly switching back and forth when the config is changed and the migration is modifying the rest to be www.openshift.com then I think this bug can be closed.
Comment 2 Yujie Zhang 2013-11-19 21:39:07 EST
(In reply to Jessica Forrester from comment #1)
hi Jessica, thanks for your comments. Ran the script as above, and the sign up links on community site can be changed to www.openshift.com/app/account/new, you can close this bug.
One thing to remind, "Try OpenShift Online" link on http://openshift.github.io/ page, since it's not part of drupal content, migration script can not change the link, we need change it specifically, thanks.

Note You need to log in before you can comment on or make changes to this bug.