Bug 1031918 - btrfs-progs: btrfs convert segfaults when converting ext4 to btrfs
btrfs-progs: btrfs convert segfaults when converting ext4 to btrfs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: btrfs-progs (Show other bugs)
7.0
All Linux
low Severity low
: rc
: ---
Assigned To: Ric Wheeler
Filesystem QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 01:44 EST by Eryu Guan
Modified: 2014-02-23 10:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-23 10:08:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2013-11-19 01:44:52 EST
Description of problem:
xfstests btrfs/012 fails because btrfs command got segfault

--- /dev/fd/63  2013-11-19 14:22:18.115843651 +0800
+++ results/btrfs/012.out.bad   2013-11-19 14:22:17.940833800 +0800
@@ -1 +1,4 @@
 == QA output created by 012
+./tests/btrfs/012: line 78: 10948 Segmentation fault      $BTRFS_CONVERT_PROG $SCRATCH_DEV >> $seqres.full 2>&1
+btrfs-convert failed
+(see /var/lib/xfstests/results//btrfs/012.full for details)

dmesg says
btrfs-convert[17526]: segfault at ac ip 00007f76ec446270 sp 00007fff904332c8 error 4 in libc-2.17.so[7f76ec3b7000+1b6000]

Version-Release number of selected component (if applicable):
btrfs-progs-0.20.rc1.20130917git194aa4a-1.el7

How reproducible:
always

Steps to Reproduce:
1. check btrfs/012 on btrfs
2.
3.

Actual results:
btrfs segfaults

Expected results:
convert successfully

Additional info:
Comment 2 Eryu Guan 2014-02-23 10:08:48 EST
Fixed in btrfs-progs-3.12-4.el7, closed.

Note You need to log in before you can comment on or make changes to this bug.