Bug 103193 - Traceback running up2date (GUI mode)
Summary: Traceback running up2date (GUI mode)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 2.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-27 16:14 UTC by Glen A. Foster
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 17:38:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glen A. Foster 2003-08-27 16:14:20 UTC
Description of problem: I ran up2date on our lab's "reference x86 box" running
AS2.1 -- I hadn't updated it since 25-Jun, so there were a few packages to
update (list included at the bottom).  After downloading the packages and
installing them, the GUI screen essentially hung.  I was running the SMP kernel
2.4.9-e.25 when this happened.  Looking at the shell window where I (luckily)
spawned up2date by hand, I noticed:

# up2date
Traceback (innermost last):
  File "/usr/share/rhn/up2date_client/gui.py", line 909, in doInstallation
    up2date.installBootLoader(kernelsToInstall)
  File "/usr/share/rhn/up2date_client/up2date.py", line 608, in installBootLoader
    __install_grub(kernelList)
  File "/usr/share/rhn/up2date_client/up2date.py", line 624, in __install_grub
    ret  = grubcfg.installNewImages(kernelList,test=0)
AttributeError: installNewImages

... after making the up2date window disappear, I ran up2date again, and it told
me there are no new packages to upgrade.  It's just weird and I thought I should
report this, regardless of how difficult it might be to reproduce.

Version-Release number of selected component (if applicable):
# rpm -q up2date kernel-smp
up2date-2.8.45-1.2.1AS
kernel-smp-2.4.9-e.3
kernel-smp-2.4.9-e.16
kernel-smp-2.4.9-e.25

How reproducible: I have no clue how reproducible this is, so in lieu of that,
I'll append the list of RPMs upgraded.

Steps to Reproduce:
1. Install RHAS 2.1 everything install
2. Occasionally upgrade via RHN -- last one was 25-Jun-2003
3. Upgrade on 27-Aug-2003
    
Actual results: Traceback

Expected results: No traceback

Additional info: Packages retreived from RHN server and upgraded were:

nscd-2.2.4-32.8.i386.rpm
arts-2.2.2-9.i386.rpm
ethereal-gnome-0.9.13-1.AS21.1.i386.rpm
gdm-2.2.3.1-20.1.i386.rpm
glibc-2.2.4-32.8.i686.rpm
glibc-common-2.2.4-32.8.i386.rpm
glibc-devel-2.2.4-32.8.i386.rpm
glibc-profile-2.2.4-32.8.i386.rpm
kdelibs-2.2.2-9.i386.rpm
kdelibs-devel-2.2.2-9.i386.rpm
kdelibs-sound-2.2.2-9.i386.rpm
kdelibs-sound-devel-2.2.2-9.i386.rpm
kernel-2.4.9-e.27.i686.rpm
kernel-debug-2.4.9-e.27.i686.rpm
kernel-doc-2.4.9-e.27.i386.rpm
kernel-headers-2.4.9-e.27.i386.rpm
kernel-smp-2.4.9-e.27.i686.rpm
kernel-source-2.4.9-e.27.i386.rpm
openssh-3.1p1-8.i386.rpm
openssh-askpass-3.1p1-8.i386.rpm
openssh-askpass-gnome-3.1p1-8.i386.rpm
openssh-clients-3.1p1-8.i386.rpm
openssh-server-3.1p1-8.i386.rpm
unzip-5.50-30.i386.rpm
xpdf-0.92-10.i386.rpm
ddskk-11.6.0-1.7.ent.noarch.rpm
ethereal-0.9.13-1.AS21.1.i386.rpm
hanterm-xf-2.0.5-5.AS21.1.i386.rpm
mysqlclient9-3.23.22-8.i386.rpm
netscape-common-4.8-1.i386.rpm
netscape-communicator-4.8-1.i386.rpm
netscape-navigator-4.8-1.i386.rpm
nfs-utils-0.3.3-7.21AS.i386.rpm
openldap12-1.2.13-8.i386.rpm
pam_smb-1.1.6-9.7.i386.rpm
stunnel-3.22-5.7.3.i386.rpm
tetex-doc-1.0.7-38.4.i386.rpm
wu-ftpd-2.6.1-21.i386.rpm

Comment 1 Adrian Likins 2003-08-29 23:06:17 UTC
grab the errata packages, this fix is included 2.8.46

Comment 2 Suzanne Hillman 2003-10-03 17:38:05 UTC
Has been over a month since a solution was indicated, with no followups saying
it's still broken. So, I'm closing this. If there is still a problem, please reopen.


Note You need to log in before you can comment on or make changes to this bug.