Bug 1031930 - SELinux is preventing /usr/bin/gnome-keyring-daemon from 'create' accesses on the sock_file control.
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'create' accesses on...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:561d304071cb63edecd2e9facaf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 02:26 EST by Igor Vucenovic
Modified: 2014-01-19 22:08 EST (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-74.17.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-19 22:08:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Vucenovic 2013-11-19 02:26:38 EST
Description of problem:
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'create' accesses on the sock_file control.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gnome-keyring-daemon should be allowed create access on the control sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:cache_home_t:s0
Target Objects                control [ sock_file ]
Source                        gnome-keyring-d
Source Path                   /usr/bin/gnome-keyring-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-keyring-3.8.2-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.10.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.4-201.fc19.x86_64 #1 SMP Thu
                              Oct 10 14:11:18 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-11-06 08:59:40 CET
Last Seen                     2013-11-06 08:59:40 CET
Local ID                      6eca04c7-7ce3-4f88-b83f-c60f93f6088b

Raw Audit Messages
type=AVC msg=audit(1383724780.444:5372): avc:  denied  { create } for  pid=23148 comm="gnome-keyring-d" name="control" scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:cache_home_t:s0 tclass=sock_file


type=SYSCALL msg=audit(1383724780.444:5372): arch=x86_64 syscall=bind success=no exit=EACCES a0=5 a1=7fffc631bcd0 a2=6e a3=0 items=0 ppid=23134 pid=23148 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=407 tty=pts2 comm=gnome-keyring-d exe=/usr/bin/gnome-keyring-daemon subj=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 key=(null)

Hash: gnome-keyring-d,passwd_t,cache_home_t,sock_file,create

Additional info:
reporter:       libreport-2.1.8
hashmarkername: setroubleshoot
kernel:         3.11.4-201.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-12-06 09:48:30 EST
Do you know what you were doing when this happened? Did you get it again?
Comment 2 Igor Vucenovic 2013-12-11 17:37:34 EST
(In reply to Miroslav Grepl from comment #1)
> Do you know what you were doing when this happened? Did you get it again?

I'm not sure.
Comment 3 Daniel Walsh 2013-12-16 11:01:10 EST
Looks like passwd command attempting to change the gnome-keyring value.
Comment 4 Daniel Walsh 2014-01-03 15:48:36 EST
68c7b1f53c42a38591fac700ddf298705cbcdd40 fixes this in git.
Comment 5 Lukas Vrabec 2014-01-03 18:58:25 EST
back ported.
Comment 6 Fedora Update System 2014-01-10 09:13:01 EST
selinux-policy-3.12.1-74.17.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-74.17.fc19
Comment 7 Fedora Update System 2014-01-11 03:42:18 EST
Package selinux-policy-3.12.1-74.17.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-74.17.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0636/selinux-policy-3.12.1-74.17.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-01-19 22:08:35 EST
selinux-policy-3.12.1-74.17.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.