Bug 103204 - tagged fileindex patch
Summary: tagged fileindex patch
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-27 18:24 UTC by Michael Schröder
Modified: 2009-01-30 08:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-30 08:39:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tagged index patch (4.96 KB, patch)
2003-08-27 18:25 UTC, Michael Schröder
no flags Details | Diff

Description Michael Schröder 2003-08-27 18:24:10 UTC
Here's the tagged fileindex patch. Note that a part of it breaks rpm directory
semantics (symlink disambiguation through fingerprints) so be careful.

You may want to add the exclude parameter to rpmdbFindFpList anyway, because
it doesn't break anything and makes updates faster.

Comment 1 Michael Schröder 2003-08-27 18:25:38 UTC
Created attachment 93981 [details]
tagged index patch

Comment 2 Paul Nasrat 2005-10-12 13:48:18 UTC
Update component, and set for review.

Comment 3 Jeff Johnson 2007-04-01 19:02:40 UTC
Enough review already ...

About to be fixed in rpm cvs, the patch will be in rpm-4.4.9-0.3 when built.

UPSTREAM

Comment 4 Red Hat Bugzilla 2007-08-21 05:17:38 UTC
User pnasrat@redhat.com's account has been closed

Comment 5 Panu Matilainen 2007-08-22 06:33:22 UTC
Reassigning to owner after bugzilla made a mess, sorry about the noise...

Comment 6 Panu Matilainen 2009-01-30 08:39:38 UTC
Time to close this ancient bug... WONTFIX, the insane memory use + slowness on identical basenames is fixed in rpm.org HEAD by other means.


Note You need to log in before you can comment on or make changes to this bug.