Bug 1032075 - Activating an active host does not return an error
Activating an active host does not return an error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.4.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.4.0
Assigned To: Eli Mesika
Elena
infra
: AutomationBlocker, AutomationTriaged, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 09:00 EST by Ohad Basan
Modified: 2016-02-10 14:32 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 08:36:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ohad Basan 2013-11-19 09:00:37 EST
Description of problem:

when activating an active host the expected REST call should be :
2013-11-19 13:43:13,036 - MainThread - hosts - DEBUG - Response body for action request is: 
<action>
    <async>false</async>
    <grace_period>
        <expiry>10</expiry>
    </grace_period>
    <status>
        <state>failed</state>
    </status>
    <fault>
        <reason>Operation Failed</reason>
        <detail>[Cannot activate Host. Host in Up status.]</detail>
    </fault>
</action>

on RHEV3.4 nothing returns
Comment 2 Eli Mesika 2013-11-20 10:25:41 EST
Unable to reproduce 

Sending a POST request to an active Host with the following body 

<action>
    <async>false</async>
    <grace_period>
        <expiry>10</expiry>
    </grace_period>
</action>

Resulted in the following respond :

<action>
<async>false</async>
<grace_period>
<expiry>10</expiry>
</grace_period>
<status>
<state>failed</state>
</status>
<fault>
<reason>Operation Failed</reason>
<detail>[Cannot activate Host. Host in Up status.]</detail>
</fault>
</action>

Looking in the code , there is a canDoAction code that generates an error when Activate is called and the Host is UP

Please check that Host did not change status between the time the last status is retrieved and the call to activate the host
Comment 3 Ohad Basan 2013-11-20 11:19:56 EST
I See it also in other tests.
meaning it's not specific to activate hosts
for example, set host to maintenance also doesn't respond
Comment 5 Eli Mesika 2013-11-21 08:05:31 EST
related to the caching mechanism added lately.
Please check again after the following revert patches are merged :

http://gerrit.ovirt.org/#/c/21473/
http://gerrit.ovirt.org/#/c/21474/
http://gerrit.ovirt.org/#/c/21475/
http://gerrit.ovirt.org/#/c/21476/
Comment 6 Eyal Edri 2013-11-21 08:14:19 EST
kiril - can you update status on this after fixed qe code?
Comment 8 Eli Mesika 2013-11-24 04:25:13 EST
Please check if still hapenning after reverting Host caching 

Thanks
Comment 9 Eyal Edri 2013-11-24 05:09:39 EST
it's still happening.
we believe it's bug in QE code, following ticket opened on comment #7.
Comment 10 Eli Mesika 2013-11-25 05:09:03 EST
Elena , please update if this is a QE BZ so I can close it

Note You need to log in before you can comment on or make changes to this bug.