Bug 1032081 - Enable quorum in profile virt
Enable quorum in profile virt
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Vijaikumar Mallikarjuna
SATHEESARAN
: ZStream
Depends On: 1032080
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 09:09 EST by Vijay Bellur
Modified: 2016-05-11 18:47 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.49rhs-1.el6rhs
Doc Type: Bug Fix
Doc Text:
To prevent occurrences of split-brain, when a volume is used for storing virtual machine images, it would be necessary to enable both client and server side quorum in the virt profile.
Story Points: ---
Clone Of: 1032080
Environment:
Last Closed: 2014-02-25 03:04:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0208 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 07:20:30 EST

  None (edit)
Description Vijay Bellur 2013-11-19 09:09:23 EST
+++ This bug was initially created as a clone of Bug #1032080 +++

Description of problem:

To prevent occurrences of split-brain when a volume is used for storing virtual machine images, it would be necessary to enable both client and server side quorum. The tunables that are necessary for enabling quorum need to be part of the virt profile which gets packaged with glusterfs.


Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Vijaikumar Mallikarjuna 2013-12-12 05:19:39 EST
Patch can be found here: https://code.engineering.redhat.com/gerrit/#/c/17207/
Comment 3 SATHEESARAN 2013-12-19 08:54:05 EST
Verified with glusterfs-3.4.0.51rhs.el6rhs

[root@rhss1 ~]# cat /var/lib/glusterd/groups/virt 
quick-read=off
read-ahead=off
io-cache=off
stat-prefetch=off
eager-lock=enable
remote-dio=enable
quorum-type=auto
server-quorum-type=server

[root@rhss1 ~]# gluster volume set repvol group virt
volume set: success

[root@rhss1 ~]# gluster volume info repvol
 
Volume Name: repvol
Type: Replicate
Volume ID: 5d6f89d5-cedb-454f-82d0-54be33f2cb55
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: 10.70.37.86:/rhs/brick4/repdir1
Brick2: 10.70.37.187:/rhs/brick4/repdir1
Options Reconfigured:
cluster.server-quorum-type: server
cluster.quorum-type: auto
network.remote-dio: enable
cluster.eager-lock: enable
performance.stat-prefetch: off
performance.io-cache: off
performance.read-ahead: off
performance.quick-read: off
Comment 5 errata-xmlrpc 2014-02-25 03:04:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.