Bug 1032092 - rhn_register fails
rhn_register fails
Status: CLOSED DUPLICATE of bug 1032121
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 09:34 EST by Ronald Ramos
Modified: 2013-11-20 04:43 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 04:43:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Ramos 2013-11-19 09:34:23 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ronald Ramos 2013-11-19 10:29:17 EST
(In reply to Ronald Ramos from comment #0)
> Description of problem:
> 
> There was an error while applying your choice.
Este error no debió haber ocurrido. Si desea ayudarnos a mejorar este programa, por favor llene un reporte
de error en bugzilla.redhat.com. Es de gran ayuda si incluye la parte de '/var/log/up2date'. Gracias

> Version-Release number of selected component (if applicable):
> 
> rhn_register

> How reproducible:
> 
> every time


> Steps to Reproduce:
1.console: rhn_register
2.click forward
3.click forward
4. error pops up
> 
> Actual results:
> 
> There was an error while applying your choice.
Este error no debió haber ocurrido. Si desea ayudarnos a mejorar este programa, por favor llene un reporte
de error en bugzilla.redhat.com. Es de gran ayuda si incluye la parte de '/var/log/up2date'. Gracias


> Expected results:
> 
> Options to register server on RHN

> Additional info:

[Tue Nov 19 09:50:29 2013] rhn_register 
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 1886, in callAndFilterExceptions
    return function()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 324, in _chooseServerPageApply
    rhnreg.privacyText()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 314, in privacyText
    return s.registration.privacy_statement()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 194, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 319, in _request
    request, verbose=self._verbose)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 170, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 697, in send_http
    self._connection.connect()
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 195, in connect
    self.sock.init_ssl()
  File "/usr/lib/python2.4/site-packages/rhn/SSL.py", line 76, in init_ssl
    self._ctx.load_verify_locations(f)
OpenSSL.SSL.Error: []

[Tue Nov 19 09:50:45 2013] rhn_register 
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 1886, in callAndFilterExceptions
    return function()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 324, in _chooseServerPageApply
    rhnreg.privacyText()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 314, in privacyText
    return s.registration.privacy_statement()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 194, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 319, in _request
    request, verbose=self._verbose)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 170, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 697, in send_http
    self._connection.connect()
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 195, in connect
    self.sock.init_ssl()
  File "/usr/lib/python2.4/site-packages/rhn/SSL.py", line 76, in init_ssl
    self._ctx.load_verify_locations(f)
OpenSSL.SSL.Error: []
Comment 2 Milan Zázrivec 2013-11-20 04:43:43 EST

*** This bug has been marked as a duplicate of bug 1032121 ***

Note You need to log in before you can comment on or make changes to this bug.