Bug 1032107 - When using LDAP, when user logs out of web console they cannot log back in without closing browser
When using LDAP, when user logs out of web console they cannot log back in wi...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: EAP 6.3.0
Assigned To: Darran Lofthouse
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 10:00 EST by Catherine Robson
Modified: 2014-09-22 07:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-18 05:33:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
crobson: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Catherine Robson 2013-11-19 10:00:21 EST
Description of problem:  When LDAP was enabled, whenever the user logged out any logins failed until they closed the browser and restarted it again.


Version-Release number of selected component (if applicable):
6.2.0-CR1


How reproducible:
Have no reproduced on another system.  Saw this on a SA's system with LDAP enabled.  Needs reproducing.


Steps to Reproduce:
1. Enable LDAP user authentication
2. Log into web console
3. Log out of web console
4. Attempt to log back into web console --> FAILURE
5. Close browser & reopen
6. Attempt to log back into web console --> SUCCESS

Actual results:
User must close browser to log back in after logout.

Expected results:
Users should be able to log back in after logging on without closing browser.
Comment 1 Darran Lofthouse 2013-11-20 08:10:58 EST
Pass my way if you want first Harald, we do have a change needed to the logout handler first for BASIC auth.
Comment 2 Harald Pehl 2013-11-20 08:58:33 EST
I'm afraid we'll never get this right, until we implement https://issues.jboss.org/browse/HAL-96.
Comment 3 Darran Lofthouse 2013-11-20 09:08:16 EST
Upstream now is probably a good time to be getting this in.

For EAP however that will be a bigger job due to being a different HTTP server.
Comment 4 Darran Lofthouse 2014-07-08 09:58:20 EDT
Is this still an issue with EAP 6.3?  We did revisit HTTP BASIC logout handling in EAP 6.3 so this may already be fixed.
Comment 5 Petr Kremensky 2014-07-18 05:33:55 EDT
This is no longer an issue in 6.3.0 (tested with EAP 6.3.0.ER10), thus closing.

Note You need to log in before you can comment on or make changes to this bug.