Bug 1032121 - rhn_register fails
rhn_register fails
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
: 1032092 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 10:16 EST by Ronald Ramos
Modified: 2013-12-10 07:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 07:04:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Ramos 2013-11-19 10:16:20 EST
Description of problem:

There was an error while applying your choice.
Este error no debió haber ocurrido. Si desea ayudarnos a mejorar este programa, por favor llene un reporte
de error en bugzilla.redhat.com. Es de gran ayuda si incluye la parte de '/var/log/up2date'. Gracias

Version-Release number of selected component (if applicable):

rhn_register

How reproducible:

every time

Steps to Reproduce:
1.console: rhn_register
2.click forward
3.click forward
4. error pops up

Actual results:

There was an error while applying your choice.
Este error no debió haber ocurrido. Si desea ayudarnos a mejorar este programa, por favor llene un reporte
de error en bugzilla.redhat.com. Es de gran ayuda si incluye la parte de '/var/log/up2date'. Gracias


Expected results:

Options to register server on RHN.


Additional info:

[Tue Nov 19 09:50:29 2013] rhn_register 
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 1886, in callAndFilterExceptions
    return function()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 324, in _chooseServerPageApply
    rhnreg.privacyText()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 314, in privacyText
    return s.registration.privacy_statement()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 194, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 319, in _request
    request, verbose=self._verbose)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 170, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 697, in send_http
    self._connection.connect()
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 195, in connect
    self.sock.init_ssl()
  File "/usr/lib/python2.4/site-packages/rhn/SSL.py", line 76, in init_ssl
    self._ctx.load_verify_locations(f)
OpenSSL.SSL.Error: []

[Tue Nov 19 09:50:45 2013] rhn_register 
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 1886, in callAndFilterExceptions
    return function()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 324, in _chooseServerPageApply
    rhnreg.privacyText()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 314, in privacyText
    return s.registration.privacy_statement()
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 50, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 194, in doCall
    ret = method(*args, **kwargs)
  File "/usr/lib/python2.4/xmlrpclib.py", line 1096, in __call__
    return self.__send(self.__name, args)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 38, in _request1
    ret = self._request(methodname, params)
  File "/usr/lib/python2.4/site-packages/rhn/rpclib.py", line 319, in _request
    request, verbose=self._verbose)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 170, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.4/site-packages/rhn/transports.py", line 697, in send_http
    self._connection.connect()
  File "/usr/lib/python2.4/site-packages/rhn/connections.py", line 195, in connect
    self.sock.init_ssl()
  File "/usr/lib/python2.4/site-packages/rhn/SSL.py", line 76, in init_ssl
    self._ctx.load_verify_locations(f)
OpenSSL.SSL.Error: []
Comment 1 Milan Zázrivec 2013-11-20 04:43:43 EST
*** Bug 1032092 has been marked as a duplicate of this bug. ***
Comment 2 Milan Zázrivec 2013-11-20 06:00:44 EST
Is this a registration with Red Hat Network or with Red Hat Network Satellite?
Comment 3 Ronald Ramos 2013-11-20 08:34:18 EST
(In reply to Milan Zazrivec from comment #2)
> Is this a registration with Red Hat Network or with Red Hat Network
> Satellite?

Is a registration with Red Hat Network
Comment 4 Milan Zázrivec 2013-11-20 08:39:19 EST
All right, which version of rhn-client-tools is this?

Does synchronizing system clock help the issue? (rdate -s ...)
Comment 5 Ronald Ramos 2013-11-25 09:10:54 EST
(In reply to Milan Zazrivec from comment #4)
> All right, which version of rhn-client-tools is this?
> 
> Does synchronizing system clock help the issue? (rdate -s ...)

version of rhn-client-tools:

# rhn_register --version
rhn_register (Red Hat Network Client Tools) 0.4.17-8.el5
Copyright (C) 1999-2006 Red Hat, Inc.
Licenciado bajo los términos del GPL.

--------------------------------------------------------

rdate -s show time out, I try with command ntpdate.

# rdate -s 0.rhel.pool.ntp.org
rdate: timeout for 0.rhel.pool.ntp.org

# ntpdate -u 0.rhel.pool.ntp.org
25 Nov 09:22:48 ntpdate[26982]: adjust time server 146.164.53.65 offset -0.001133 sec

After of server sync... I run rhn_register command, but show the same error.
Comment 6 Milan Zázrivec 2013-11-25 10:37:46 EST
OK, the rhn-client-tools version that we're looking at is more than
5 years old.

We've since released 8 RHEL update releases, in particular, in 2010 we
released a rhn-client-tools build, which contains updated CA certificate
for Red Hat Network.

Chances are, you're not using the latest CA certificate and are getting
the error above b/c of that.

My suggestion at this point is to update -- either the whole RHEL
or rhn-client-tools (+ dependent packages) to the latest released
version & re-try the registration.
Comment 7 Clifford Perry 2013-12-10 07:04:23 EST
Please open a support ticket, should you require further assistance. 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.