Bug 1032174 - Document gdb version requirement for showing exit code of debugged process in Eclipse
Document gdb version requirement for showing exit code of debugged process in...
Status: CLOSED NOTABUG
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: doc-User_Guide (Show other bugs)
DTS 2.1 RHEL 6
Unspecified Unspecified
unspecified Severity unspecified
: beta1
: 2.4
Assigned To: Jaromir Hradilek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 11:30 EST by Miloš Prchlík
Modified: 2014-03-06 17:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-06 17:34:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloš Prchlík 2013-11-19 11:30:11 EST
As can be seen here [1], Eclipse in DTS 2.1 will be able to correctly display exit code of debugged process. This functionality is limited by minimal required version of gdb - 7.3 and higher - and this is not fulfilled even by gdb shipped with RHEL 6.5 (7.2-60). Therefore this functionality is not available when only devtoolset-2-ide metapackage is installed and user uses RHEL toolchain (e.g. "only Eclipse and nothing else" usage scenario). Since [1] is part of Eclipse erratum, I belive this could/should be noted.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=910376
Comment 1 Jaromir Hradilek 2013-11-21 16:06:38 EST
Thank you very much for taking the time to report this issue, Milos.

Note You need to log in before you can comment on or make changes to this bug.