Bug 1032231 - Cannot restart my openshift application tomcat
Cannot restart my openshift application tomcat
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Mace
libra bugs
: SupportQuestion
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 13:30 EST by Myroslav
Modified: 2015-05-14 20:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 13:05:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Myroslav 2013-11-19 13:30:44 EST
Description of problem:
Cannot restart my openshift application tomcat

Version-Release number of selected component (if applicable):


How reproducible:
Click on restart button

Steps to Reproduce:
1.Click on restart button
2.
3.

Actual results:
Application does not restart

Expected results:
Application restarts

Additional info:
Comment 1 Yujie Zhang 2013-11-19 21:21:37 EST
Tried on prod, restarted my application tomcat6 and tomcat7, both can restart successfully, can not reproduce above issue.
Comment 2 Myroslav 2013-11-19 23:14:12 EST
tomcat-avt.rhcloud.com

I get the following when trying to restart my application via web interface
================================
We appear to be having technical difficulties

You can try refreshing the page, if the problem is temporary.

You can also try the following:

Seek assistance in the support forum.
Join IRC channel #openshift on Freenode.
If you are experiencing a repeatable error not related to a service outage, report it as a bug.
Reference #9f4bad7725b4a711590f4a806bfa8eac
Comment 3 Myroslav 2013-11-21 08:08:54 EST
Can someone restart my tomcat DIY app? Since I cannot do that from web ui due to this bug??
Comment 4 Dan Mace 2013-11-21 09:54:26 EST
Myroslav,

It appears your application gear has about 250 java processes running, which is putting you up against your process quota.

Please try force-stopping your application (e.g. `rhc app force-stop tomcat ...`) before the restart.

Let me know if that resolves your issue.
Comment 5 Myroslav 2013-11-23 16:42:12 EST
I new to open shift force-stop did work

Note You need to log in before you can comment on or make changes to this bug.