Bug 1032241 - New upstream version available
New upstream version available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glabels (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Maxim Burgerhout
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 14:00 EST by Mario Blättermann
Modified: 2013-12-19 21:07 EST (History)
4 users (show)

See Also:
Fixed In Version: glabels-3.2.0-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 21:07:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Blättermann 2013-11-19 14:00:22 EST
A new upstream version of Glabels has been released on October 28th. Please update to this version. For the recent changes, see http://www.glabels.org/.

Moreover, now it uses itstool for handling the user documentation.

Here's the download location (changed due to the new minor version):
http://ftp.gnome.org/pub/GNOME/sources/glabels/3.2/glabels-%{version}.tar.xz
Comment 1 Peter Gordon 2013-11-19 15:46:08 EST
Got it, thanks. This is first on my TODO list after class today. :)
Comment 2 Mario Blättermann 2013-11-20 14:03:52 EST
Thanks for your quick response. I've just seen the Rawhide package has been built, would it be possible to have it in the upcoming f20, too?
Comment 3 Mario Blättermann 2013-11-20 14:45:26 EST
The new version 3.2 uses itstool. Vice versa it doesn't need gnome-doc-utils anymore. Just did a scratch build on Koji without gnome-doc-utils and	gnome-doc-utils-stylesheets:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6206666
Remove them from BuildRequires. Because the g-d-u stuff is actually deprecated and will vanish one day from Gnome, it is future-proof to don't have it anymore today.
Comment 4 Peter Gordon 2013-11-21 01:17:41 EST
Thanks, Mario. I wasn't sure of that change myself, so that's why I wanted it to sit only in rawhide for a day or two to iron out any issues it (hopefully didn't) cause. I'll remove the build dependency on gnome-doc-utils and push that to rawhide and release branches between tonight and tomorrow. :)
Comment 5 Mario Blättermann 2013-11-28 04:19:51 EST
Just changed the version to f20 because I like to have the new upstream version also in the upcoming Fedora release. Don't forget to remove the gnome-doc-utils dependency.

BTW, would it make sense to request co-maintainership for me? I'm involved in upstream development for years, so I could react to changes faster.
Comment 6 Mario Blättermann 2013-12-03 15:37:11 EST
It would be nice to have Glabels v3.2 in Fedora 20 soon. @Peter, maybe you could accept Milan Crha's request to become a co-maintainer?
Comment 7 Maxim Burgerhout 2013-12-04 03:55:57 EST
I have been so free as to build glabels for Rawhide (and soon Fedora 20) without the g-d-u dependencies. I'll wait a bit with creating the Fedora 20 update until I hear from Peter, but I recon it will be done sometime later this week.
Comment 8 Maxim Burgerhout 2013-12-04 04:32:35 EST
Mmh. It seems I cannot build for Rawhide right now because of broken dependencies down the chain. Will check again later.
Comment 9 Fedora Update System 2013-12-08 15:14:58 EST
glabels-3.2.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/glabels-3.2.0-2.fc20
Comment 10 Fedora Update System 2013-12-09 15:25:04 EST
Package glabels-3.2.0-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glabels-3.2.0-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23028/glabels-3.2.0-2.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-12-19 21:07:12 EST
glabels-3.2.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.