Bug 1032364 - dbginfo.sh: avoid double data collection (s390-tools/s390utils)
dbginfo.sh: avoid double data collection (s390-tools/s390utils)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.5
s390x All
unspecified Severity medium
: rc
: 6.6
Assigned To: Dan Horák
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 22:43 EST by IBM Bug Proxy
Modified: 2013-11-20 03:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 03:52:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda logs (20.71 KB, application/octet-stream)
2013-11-19 22:44 EST, IBM Bug Proxy
no flags Details
Anaconda program logs (76.44 KB, application/octet-stream)
2013-11-19 22:44 EST, IBM Bug Proxy
no flags Details
Anaconda storage logs (230.42 KB, application/octet-stream)
2013-11-19 22:44 EST, IBM Bug Proxy
no flags Details
syslog (27.94 KB, application/octet-stream)
2013-11-19 22:44 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2013-11-19 22:43:59 EST

    
Comment 1 IBM Bug Proxy 2013-11-19 22:44:02 EST
Description:  dbginfo.sh: avoid double data collection
Symptom:      Execution of dbginfo.sh fails with 'no space left on device'
Problem:      The data collection of the dbginfo.sh script collects two times
              entries from the sysfs. First, the script itself collects
              all 'files' and later on, the script ziomon_fcpconf is
              collecting a subset of the sysfs along with some additional
              data. The additional data (information about the /dev entries)
              is collected by the dbginfo.sh script also. Therefore, the
              execution of ziomon_fcpconf is obsolete.
Solution:     Avoid the execution of ziomon_fcpconf in the dbginfo.sh script
Reproduction: Run the dbginfo.sh script on a machine, where /tmp should be
              able to cover the amount of data being collected. The machine
              should have quite a lot of devices being attached.
Upstream-ID:  -

Signed-off-by: Wolfgang Taphorn <taphorn@de.ibm.com>
Comment 2 IBM Bug Proxy 2013-11-19 22:44:11 EST
Created attachment 826406 [details]
Anaconda logs



This issue is observed in RHEL6.5 RC1

Steps to reproduce this issue
1. Attach 2 Hyperpav base devices and alias in zvm 
2. Add all necessary parameters in param file including hyperpav base and alias.
3. Start the installation. Select vnc mode of installation
4. Use hyperpav base for installation.
5. Reboot the machine.
6. list hyperpav base devices and alias

Actual : Only hyperpav base devices are listed.
Expected : Must be able to list hyperpav base and alias


Hyperpav alias are listed on manual alias online.



[root@hostname ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.5 (Santiago)
Kernel \r on an \m

[root@hostname ~]# lsdasd
Bus-ID     Status      Name      Device  Type  BlkSz  Size      Blocks
==============================================================================
0.0.8700   active      dasda     94:0    ECKD  4096   2347MB    601020
0.0.6384   active      dasdb     94:4    ECKD  4096   7043MB    1803060
0.0.8701   active      dasdc     94:8    ECKD  4096   2347MB    601020
[root@hostname ~]# lsdasd -u
Bus-ID    Name      UID
==============================================================================
0.0.6384  dasdb     IBM.750000000DHVL1.6300.84.00000000000027200000000000000000
0.0.8700  dasda     IBM.750000000R0021.8700.00.0000000000000d0a0000000000000000
0.0.8701  dasdc     IBM.750000000R0021.8700.01.0000000000000d0a0000000000000000
[root@hostname ~]# uname -a
Linux hostname.boeblingen.de.ibm.com 2.6.32-431.el6.s390x #1 SMP Sun Nov 10 22:21:52 EST 2013 s390x s390x s390x GNU/Linux
Comment 3 IBM Bug Proxy 2013-11-19 22:44:14 EST
Created attachment 826407 [details]
Anaconda program logs
Comment 4 IBM Bug Proxy 2013-11-19 22:44:17 EST
Created attachment 826408 [details]
Anaconda storage logs
Comment 5 IBM Bug Proxy 2013-11-19 22:44:20 EST
Created attachment 826409 [details]
syslog
Comment 6 IBM Bug Proxy 2013-11-19 22:44:27 EST
Manually online hyperpav alias

[root@hostname ~]# cio_ignore -R
[root@hostname ~]# chccwdev -e 87c0-87c3
Setting device 0.0.87c0 online
Done
Setting device 0.0.87c1 online
Done
Setting device 0.0.87c2 online
Done
Setting device 0.0.87c3 online
Done
[root@hostname ~]# lsdasd
Bus-ID     Status      Name      Device  Type  BlkSz  Size      Blocks
==============================================================================
0.0.87c0   alias                         ECKD
0.0.87c1   alias                         ECKD
0.0.87c2   alias                         ECKD
0.0.87c3   alias                         ECKD
0.0.8700   active      dasda     94:0    ECKD  4096   2347MB    601020
0.0.6384   active      dasdb     94:4    ECKD  4096   7043MB    1803060
0.0.8701   active      dasdc     94:8    ECKD  4096   2347MB    601020
Comment 8 Hanns-Joachim Uhl 2013-11-20 03:52:41 EST
... due to mirroring problems at the IBM side closing this Red Hat bugzilla ...

Note You need to log in before you can comment on or make changes to this bug.