Bug 1032419 - getVdsHardwareInfo fails with 'TransportWrapper instance has no attribute 'request'
getVdsHardwareInfo fails with 'TransportWrapper instance has no attribute 're...
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Piotr Kliczewski
Haim
infra
: Reopened
: 1032427 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 02:15 EST by Yedidyah Bar David
Modified: 2013-11-27 07:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 06:25:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21429 None None None Never

  None (edit)
Description Yedidyah Bar David 2013-11-20 02:15:05 EST
Description of problem:

When running 'hosted-engine --deploy' on a specific setup (a machine which already had hosted-engine installed and setup and was (partially?) cleaned up), vdsmd fails with the above. vdsm packages installed from the nightly repo of 2013-11-19.

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/system/vdsmenv.py", line 144, in _late_setup
    self._connect()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/system/vdsmenv.py", line 78, in _connect
    self.logger.debug(str(serv.s.getVdsHardwareInfo()))
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1574, in __request
    response = self.__transport.request(
AttributeError: TransportWrapper instance has no attribute 'request'
Comment 1 Yedidyah Bar David 2013-11-20 02:26:00 EST
Fails the same way also with latest nightly vdsm-4.13.0-153.git1f93f81.fc19.x86_64
Comment 2 Yedidyah Bar David 2013-11-20 02:29:52 EST
Worked around by doing:

vdsm-tool configure --force
Comment 3 Yedidyah Bar David 2013-11-20 02:33:47 EST
Sorry, it's not at all during service vdsmd start. Might be a bug in hosted-engine, I'll open one if needed.
Comment 4 Sandro Bonazzola 2013-11-20 02:38:12 EST
setup/system/vdsmenv.py", line 78, in _connect
    self.logger.debug(str(serv.s.getVdsHardwareInfo()))
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1574, in __request
    response = self.__transport.request(
AttributeError: TransportWrapper instance has no attribute 'request'

Here I'm not sure if it's a xmlrpclib.py bug or a VDSM client bug.
It seems that whoever creates the TransportWrapper used by that call is missing to define request attribute.
Comment 5 Yedidyah Bar David 2013-11-20 02:46:47 EST
*** Bug 1032427 has been marked as a duplicate of this bug. ***
Comment 6 Piotr Kliczewski 2013-11-27 06:25:36 EST
Bug do not exists after fix introduced for 982065.
Comment 7 Dan Kenigsberg 2013-11-27 07:10:37 EST
Since it WAS a bug in the master branch, a better closing reason is NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.