Bug 1032439 - jbossws testcase intermittent failures caused by javax.management.InstanceNotFoundException: jboss.ws:service=ServerConfig
Summary: jbossws testcase intermittent failures caused by javax.management.InstanceNot...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: DR3
: EAP 6.3.0
Assignee: Alessio Soldano
QA Contact: Rostislav Svoboda
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-20 08:29 UTC by Petr Sakař
Modified: 2014-06-28 15:29 UTC (History)
4 users (show)

(edit)
In previous releases of JBoss EAP 6, the WS server configuration was not always available through JMX.

This was caused by the deprecated OPTIONAL service dependency to MBean server in WS ServerConfigService

In this version, MBean server dependency is set as REQUIRED instead of OPTIONAL whenever the JMX subsystem is available

As a result, WS server configuration is always available through JMX when JMX subsystem is available
Clone Of:
(edit)
Last Closed: 2014-06-28 15:29:32 UTC


Attachments (Terms of Use)

Description Petr Sakař 2013-11-20 08:29:48 UTC
Description of problem:
JBWS1178TestCaseForked failure
		javax.management.InstanceNotFoundException: jboss.ws:service=ServerConfig
			at org.jboss.as.jmx.PluggableMBeanServerImpl.findDelegate(PluggableMBeanServerImpl.java:1083)
			at org.jboss.as.jmx.PluggableMBeanServerImpl.getAttribute(PluggableMBeanServerImpl.java:378)
			at org.jboss.remotingjmx.protocol.v2.ServerProxy$GetAttributeHandler.handle(ServerProxy.java:691)
			at org.jboss.remotingjmx.protocol.v2.ServerCommon$MessageReciever$1$1.run(ServerCommon.java:153)
			at org.jboss.as.jmx.ServerInterceptorFactory$Interceptor$1.run(ServerInterceptorFactory.java:75)
			at org.jboss.as.jmx.ServerInterceptorFactory$Interceptor$1.run(ServerInterceptorFactory.java:70)
			at java.security.AccessController.doPrivileged(Native Method)
			at javax.security.auth.Subject.doAs(Subject.java:415)
			at org.jboss.as.controller.AccessAuditContext.doAs(AccessAuditContext.java:94)
			at org.jboss.as.jmx.ServerInterceptorFactory$Interceptor.handleEvent(ServerInterceptorFactory.java:70)
			at org.jboss.remotingjmx.protocol.v2.ServerCommon$MessageReciever$1.run(ServerCommon.java:149)
			at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
			at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
			at java.lang.Thread.run(Thread.java:724)

Version-Release number of selected component (if applicable):
6.2.0

How reproducible:
intermittent

Steps to Reproduce:
1. run jbossws cxf stack testsuite

Actual results:
intermittent failures with cause javax.management.InstanceNotFoundException: jboss.ws:service=ServerConfig

Expected results:


Additional info:
Last seen on windows machine for EAP 6.2.0.CR2

Comment 1 Petr Sakař 2013-11-20 08:42:23 UTC
there was no error in the server log. most probably timing issue / thread safety

Comment 2 Petr Sakař 2014-03-04 07:36:53 UTC
seen on EAP 6.2.2 java17, w2k8r2 x86_64

also failing because of same reason is org.jboss.test.ws.jaxws.jbws2150.JBWS2150TestCaseForked$JBWS2150TestSetup.org.jboss.test.ws.jaxws.jbws2150.JBWS2150TestCaseForked on java18, RHEL5 x86_64

Comment 3 Alessio Soldano 2014-03-05 10:19:40 UTC
This is caused by a race condition between JMX and WS subsystems during boot, see https://issues.jboss.org/browse/WFLY-3061.

Comment 6 Petr Sakař 2014-03-14 17:59:45 UTC
Verified no such failure present for EAP-6.3.0.DR4


Note You need to log in before you can comment on or make changes to this bug.