Bug 1032442 - [ibus-typing-booster][F20] - Support for the surrounding text needs to be implemented [RFE]
[ibus-typing-booster][F20] - Support for the surrounding text needs to be imp...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
20
All Linux
high Severity medium
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 03:34 EST by Satyabrata Maitra
Modified: 2014-01-28 22:09 EST (History)
8 users (show)

See Also:
Fixed In Version: ibus-typing-booster-1.2.9-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 22:04:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2013-11-20 03:34:17 EST
Description of problem:
In F20 TC6 as tested, the support for the   surrounding text needs to be implemented.

Version-Release number of selected component (if applicable):
ibus-typing-booster-1.2.4-3.f20
hunspell-*-0.06-4.fc20

How reproducible:
Always

Steps to Reproduce:
1. Add hunspell or typing-booster input source for any locale from Region & 
   Language settings.
   (Here I consider typing-booster:bn-IN or hunspell:bn-IN for example and 
   taken itrans as keymaps)
2. Select the keymaps mentioned in step 1.
3. For example type "baag" and press "SPACE" key
4. Observe the candidate window with predictive words disappears as soon as 
   user press the "SPACE"
5. Now press "LEFT ARROW KEY" once
6. Observe the text.

Actual results:
After step 6, the text does not get selected again to let the same previous candidate window with same predictive word list appeared.

Expected results:
The text should get selected again as before (when user typed "baag") and the same candidate window with the same predictive word list should appear.

Additional info: Even if you press "BACKSPACE" instead of navigation key (LEFT ARROW KEY) the result remains the same.
Comment 1 Pravin Satpute 2013-11-20 03:38:55 EST
This issue was observed by Krishnababu in testing event we had yesterday. 

So it often happen we do not get exact word suggestions from candidate list and user commit the part of word and try to again edit it.

But during edit itb start showing new suggestion based on last part of word. So having surrounding text will help users to get appropriate suggestion and also appropriate words will get added in user db.
Comment 2 Mike FABIAN 2013-11-20 04:20:22 EST
Yes, I thought about such a feature as well a while ago.
Would be nice. I’ll try to implement it.
Comment 3 Pravin Satpute 2013-11-21 11:27:04 EST
Thats nice. I saw the same feature on default predictive IME on Android as well.
Comment 4 Fedora Update System 2014-01-17 11:25:48 EST
ibus-typing-booster-1.2.9-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.9-1.fc20
Comment 5 Fedora Update System 2014-01-17 11:27:17 EST
ibus-typing-booster-1.2.9-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.9-1.fc19
Comment 6 Fedora Update System 2014-01-17 23:25:10 EST
Package ibus-typing-booster-1.2.9-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-1.2.9-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1061/ibus-typing-booster-1.2.9-1.fc19
then log in and leave karma (feedback).
Comment 7 Mike FABIAN 2014-01-20 02:12:07 EST
The above change implements the reopening of the preedit only
for backspace, not for the arrow keys. Doing it for the arrow
keys is more difficult, I am still trying to figure out how
to do it. But I wanted to release the fix for backspace because this
works already.
Comment 8 Fedora Update System 2014-01-28 22:04:24 EST
ibus-typing-booster-1.2.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-01-28 22:09:01 EST
ibus-typing-booster-1.2.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.