Bug 1032504 - [ml_IN][ibus-typing-booster][F20] - 200D does not get committed in user db when it comes at the end
Summary: [ml_IN][ibus-typing-booster][F20] - 200D does not get committed in user db wh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 20
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-20 10:13 UTC by Satyabrata Maitra
Modified: 2013-12-14 03:32 UTC (History)
8 users (show)

Fixed In Version: ibus-typing-booster-1.2.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-11 02:01:57 UTC


Attachments (Terms of Use)
Screen shot 1 (33.52 KB, image/png)
2013-11-20 10:13 UTC, Satyabrata Maitra
no flags Details
Screen shot 2 (51.56 KB, image/png)
2013-11-20 10:14 UTC, Satyabrata Maitra
no flags Details
0001-Don-t-strip-characters-with-Unicode-category-Cf-Othe.patch (2.34 KB, patch)
2013-11-20 12:43 UTC, Mike FABIAN
no flags Details | Diff

Description Satyabrata Maitra 2013-11-20 10:13:53 UTC
Created attachment 826522 [details]
Screen shot 1

Description of problem:
When comes or get placed at the end of a word, 200D does not get committed in the userdb as soon as it typed in the user db. Only the part which typed before typing 200D gets committed and shows in user db.
It does get committed well when it comes in the middle of any word and shows properly in the candidate window.

Version-Release number of selected component (if applicable):
ibus-typing-booster-1.2.4-3.fc20
hunspell-ml-0.1-10.fc20

How reproducible:
Always

Steps to Reproduce:
1. Add ml-IN hunspell or typing-booster input source for malayalam from Region 
   & Language settings with inscript keymap.
2. Open gedit ans select ml_IN input source from the panel
3. With the Inscript Keymap enabled, type a word with the key sequence : 
   SHIFT h + f + n + d + ] + m + Shift c + d + ]
4. Press SPACE once.
5. Repeat typing the same word in the next line or so
6. Observe the candidate list appearing.

Actual results:
Here I would like to explain the word a bit, which I got from Apeter. n+d+] denotes the first chillu character ended up with (]) which is 200D. And it comes well. The Shift c+d+] is the last character which also ends up with (]) which is 200D. And the problem is in when it ends with (]) which is 200D.

Expected results:
The 200D character should get committed in the user db ans show properly in the candidate window.

Additional info:
2 screen shot attached for the reference and the better understanding of the bug.
The word typed on the step 3 can be verified and compared visually by the Screen shot 1 attached. and the Detail is provided in the screen shot 2.

Comment 1 Satyabrata Maitra 2013-11-20 10:14:30 UTC
Created attachment 826523 [details]
Screen shot 2

Comment 2 Mike FABIAN 2013-11-20 12:43:26 UTC
Created attachment 826608 [details]
0001-Don-t-strip-characters-with-Unicode-category-Cf-Othe.patch

Patch to solve the problem.

Comment 3 Fedora Update System 2013-11-20 14:49:31 UTC
ibus-typing-booster-1.2.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.7-1.fc18

Comment 4 Fedora Update System 2013-11-20 14:51:28 UTC
ibus-typing-booster-1.2.7-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.7-1.fc19

Comment 5 Fedora Update System 2013-11-20 14:52:58 UTC
ibus-typing-booster-1.2.7-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.7-1.fc20

Comment 6 Fedora Update System 2013-11-23 19:29:17 UTC
Package ibus-typing-booster-1.2.7-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-1.2.7-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21878/ibus-typing-booster-1.2.7-1.fc19
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-12-11 02:01:57 UTC
ibus-typing-booster-1.2.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2013-12-11 02:02:59 UTC
ibus-typing-booster-1.2.7-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-12-14 03:32:19 UTC
ibus-typing-booster-1.2.7-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.