Bug 1032546 - fpdns doesn't seem to work (unknown opcode NS_NOTIFY_OP)
fpdns doesn't seem to work (unknown opcode NS_NOTIFY_OP)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fpdns (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mark McKinstry
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 06:39 EST by Need Real Name
Modified: 2014-01-17 00:44 EST (History)
3 users (show)

See Also:
Fixed In Version: fpdns-0.10.0-20131119.1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 00:44:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2013-11-20 06:39:43 EST
Description of problem:
# fpdns -Df redhat.com
header->qdcount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2174.
header->ancount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2175.
header->nscount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2176.
header->arcount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2177.
header->qdcount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2174.
header->ancount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2175.
header->nscount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2176.
header->arcount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2177.
header->qdcount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2174.
header->ancount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2175.
header->nscount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2176.
header->arcount attribute is read-only at /usr/share/perl5/vendor_perl/Net/DNS/Fingerprint.pm line 2177.
unknown opcode NS_NOTIFY_OP at /usr/lib64/perl5/vendor_perl/Net/DNS/Parameters.pm line 253.


Version-Release number of selected component (if applicable):
fpdns-0.10.0-20121022.1.fc20.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mark McKinstry 2013-11-30 12:28:33 EST
Hello,

Thanks for the bug report. It looks like fpdns is also aware of the issue and fixed it by submitting a change to perl-Net-DNS: https://github.com/kirei/fpdns/issues/6

It looks like perl-Net-DNS just released a new version (0.73) yesterday which includes the fix the fpdns author sent to them. I'll test it out and confirm it does fix it.
Comment 2 Mark McKinstry 2014-01-07 20:39:16 EST
Hello,

I've confirmed this is fixed and fpdns is working on f20. It works but still throws an error about header->qdcount which is fixed in the version I just checked in to git.
Comment 3 Fedora Update System 2014-01-07 20:42:27 EST
fpdns-0.10.0-20131119.1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fpdns-0.10.0-20131119.1.fc20
Comment 4 lnie 2014-01-07 21:51:25 EST
tested with fpdns-0.10.0-20131119.1.fc20,header->qdcount error is gone
Comment 5 Christopher Meng 2014-01-08 02:07:33 EST
Tested.
Comment 6 Fedora Update System 2014-01-09 02:38:10 EST
Package fpdns-0.10.0-20131119.1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fpdns-0.10.0-20131119.1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0446/fpdns-0.10.0-20131119.1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-01-17 00:44:20 EST
fpdns-0.10.0-20131119.1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.