Bug 1032612 - kde-workspace: false lock screen as screensaver
kde-workspace: false lock screen as screensaver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
19
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 08:24 EST by Ratul Gupta
Modified: 2014-01-27 03:51 EST (History)
9 users (show)

See Also:
Fixed In Version: kde-workspace-4.11.3-5.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 08:47:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ratul Gupta 2013-11-20 08:24:53 EST
Description of problem:
The screen locker in KDE shows a password prompt as screensaver, but doesn't prompt for the password before the specified time, thus can confuse some user to enter password when it's just a screensaver.

Version-Release number of selected component (if applicable):
Fedora 19 with kde-workspace 4.11.2.

How reproducible:


Steps to Reproduce:
1. Go to System Settings -> Display -> Screen Locker.
2. Enable "Start Automatically After", and keep the "Require Password after" unchecked.
3. After the specified time, the screen would show the lock screen as the screensaver.
Actual results:
The Lock screen is displayed as the screensaver, which could give a false sense to the user that the screen is locked, which infact is just a screensaver, which could be bypassed by either moving the mouse or pressing a key.

Expected results:
The default screensaver should not atleast be this confusing, a blank screen would be a better default screensaver.

Additional info:
Comment 1 Rex Dieter 2013-11-21 08:47:38 EST
That's by design to not require password unless you check "Require password..." option box.

I'd suggest contacting upstream if you disagree with it.
Comment 2 Rex Dieter 2013-11-23 02:40:06 EST
Good news, looks like this will be fixed soon (in kde-4.11.4), see also:
http://aseigo.blogspot.com/2013/11/what-trains-are-for.html
Comment 3 Fedora Update System 2013-11-23 19:45:06 EST
kde-workspace-4.11.3-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kde-workspace-4.11.3-4.fc20
Comment 4 Fedora Update System 2013-12-13 21:55:53 EST
kde-workspace-4.11.3-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.