Bug 1032645 - setroubleshoot needs a dep on python-report
setroubleshoot needs a dep on python-report
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 09:15 EST by Cole Robinson
Modified: 2013-11-25 23:53 EST (History)
2 users (show)

See Also:
Fixed In Version: setroubleshoot-3.2.14-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 23:53:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2013-11-20 09:15:16 EST
Sealert gave me this error:

Traceback (most recent call last):
  File "/usr/bin/sealert", line 650, in <module>
    run_as_dbus_service(username)
  File "/usr/bin/sealert", line 109, in run_as_dbus_service
    app = SEAlert(user, dbus_service.presentation_manager, watch_setroubleshootd=True)
  File "/usr/bin/sealert", line 320, in __init__
    from setroubleshoot.browser import BrowserApplet
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/browser.py", line 44, in <module>
    import report
ImportError: No module named report


Looks like setroubleshoot needs a dep on python-report
Comment 1 Daniel Walsh 2013-11-20 09:37:28 EST
fixed in setroubleshoot-3.2.14-2.fc20
Comment 2 Cole Robinson 2013-11-20 09:47:42 EST
Wait, I might have screwed this up. Double checking
Comment 3 Cole Robinson 2013-11-20 09:50:15 EST
Yeah this is a bogus report. 1) the package is libreport-python, python-report doesn't exist. 2) setroubleshoot does seem to depend on it, though indirectly. but for whatever reason, libreport-python was installed on my machine but the module wasn't there. reinstall fixed it though.

So you should probably undo any change relating to 'python-report'. Sorry for the confusion.
Comment 4 Daniel Walsh 2013-11-20 09:57:05 EST
setroubleshoot required libreport-gtk, which does not seem to bring in libreport-python.

rpm -q --requires setroubleshoot | grep report
libreport-gtk

 rpm -q --requires libreport-python | grep report
libreport = 2.1.9-1.fc21
libreport.so.0()(64bit)


I am not sure you are wrong.
Comment 5 Daniel Walsh 2013-11-20 09:57:54 EST
yum remove libreport-python , does not attempt to remove setroubleshoot.
Comment 6 Cole Robinson 2013-11-20 10:03:59 EST
Ah okay, I was afraid you took my request at face value and just added python-report to the spec.
Comment 7 Daniel Walsh 2013-11-20 10:15:19 EST
Ordinarily I would,but I saw the requirement for libreport-gtk, and was surprised that it did not get the right stuff.  Then I investigated further.

Since abrt pulls in libreport-python, it is not a huge problem, but I will push out a fix when the package finished building.

Probably need fix in rhel7 also.
Comment 8 Fedora Update System 2013-11-20 10:19:26 EST
setroubleshoot-3.2.14-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/setroubleshoot-3.2.14-2.fc20
Comment 9 Fedora Update System 2013-11-23 22:27:26 EST
Package setroubleshoot-3.2.14-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing setroubleshoot-3.2.14-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21915/setroubleshoot-3.2.14-2.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-11-25 23:53:26 EST
setroubleshoot-3.2.14-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.