Bug 1032664 - Dokuwiki ACL Not Working [NEEDINFO]
Dokuwiki ACL Not Working
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dokuwiki (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Andrew Colin Kissa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 09:44 EST by KitchM
Modified: 2013-12-17 16:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 08:30:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tech: needinfo? (extras-qa)


Attachments (Terms of Use)
No options shown (54.38 KB, image/png)
2013-11-20 09:44 EST, KitchM
no flags Details

  None (edit)
Description KitchM 2013-11-20 09:44:39 EST
Created attachment 826682 [details]
No options shown

Description of problem:
Dokuwiki package appears to be missing components to allow it to work correctly with admin rights.  There are missing parts including the Plugin Manager, the access manager and other configuration parts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open browser tab
2. Select http://localhost/dokuwiki/doku.php?
3. Get opening screen with no configuration options

Actual results:
No way to configure

Expected results:
Should have all normal functions.

Additional info:
Comment 1 Adam Tkac 2013-12-12 09:37:16 EST
Currently you have to setup ACLs manually, in /etc/dokuwiki directory. The fix for this might be to ship install.php file (which is currently not shipped) which allows you to setup permissions more user-friedly way than setting them in /etc/dokuwiki.

Andrew, do you remember why install.php is removed in dokuwiki.spec? Is there any reason for it or can I remove the statement which removes install.php from final package? Thanks in advance for your response.
Comment 2 Andrew Colin Kissa 2013-12-17 08:16:37 EST
This was done to prevent users from making changes via the web interface.
Comment 3 Adam Tkac 2013-12-17 08:27:33 EST
(In reply to Andrew Colin Kissa from comment #2)
> This was done to prevent users from making changes via the web interface.

Wouldn't be better to list install.php in dokuwiki.httpd and allow access only from 127.0.0.1 and ::1? This would allow administrator to use install.php script to setup dokuwiki instance but this script won't be accessible to remote users. What do you think about this approach?

Otherwise if you think that install.php shouldn't be part of dokuwiki package at all, you can close this bug. Reporter can configure ACL directly in configuration files in /etc/dokuwiki (however I believe that install.php is more convenient for some people).
Comment 4 Andrew Colin Kissa 2013-12-17 08:30:30 EST
I don't think install files should be shipped in a package, that is the convention used by other packages that have an install.php file.

Closing the bug.
Comment 5 KitchM 2013-12-17 12:12:16 EST
Well, how does on setup ACLs manually?  That appears to be a blocker.
Comment 6 Andrew Colin Kissa 2013-12-17 12:18:11 EST
https://www.dokuwiki.org/acl
Comment 7 KitchM 2013-12-17 14:16:21 EST
That link starts out with:
"DokuWiki – like most wikis — is very open by default. Everyone is allowed to create, edit and delete pages."

That has nothing to do with administering the program, and is therefore essentually a falsehood.

Evidently, there are some bad assumptions in using the program.  I have never heard of a program that a given user installs that will not in turn allow that user to administer his own program.  But that is exactly what docuwiki does with this install.  That is bizarre.

The bottom line is that the package is not properly created to install all the necessary components and features.  I recommend that it be removed until it does.  Right now it is useless to any reasonable user.  And that's a damn shame.
Comment 8 Andrew Colin Kissa 2013-12-17 14:26:42 EST
You are clearly not being objective here, you are able to configure ACL's without using the install.php file - by editing the acl file, the link i provided describes the format of the ACL file several people are doing so, if you are unable to do so and prefer a gui doing it for you does not mean the package is not useful.

Let me point out to you that none of the other distro's ship an install file for dokuwiki in their package as well, that has not diminished the the usefulness of their packages.

Please get your facts correct and stop peddling falsehoods, this package is totally usable and adminster-able.

This is the last response i will be making with regards to this issue, this ticket is closed as will not fix.
Comment 9 KitchM 2013-12-17 16:04:54 EST
Your shortsightedness does not change the facts.  I used to be able to install the program without any trouble at all.  Now there is a roadblock without any simple fixes.  That the program should install with all the necessary features to administer it, goes without saying.  At this point it does not do so.  That is not a falsehood; that is a fact.

It is totally ignorant to state that it is adminser-able (sic) when in fact the administering parts of it are missing without outside work.

You are the one peddling falsehoods because you fail to understand what the user needs.  Such shortsightedness does nothing to further the cause of computing whatsoever.

This software installation routine remains half-baked.

Note You need to log in before you can comment on or make changes to this bug.