This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1032696 - FEAT: [1.6] Test tags should be added for new specifically-named tests
FEAT: [1.6] Test tags should be added for new specifically-named tests
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 10:26 EST by Greg Nichols
Modified: 2014-05-21 15:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5-20131120
Doc Type: Enhancement
Doc Text:
Test tags may now be used to run multiple tests of a given type. For example, the tag "network" will run all network tests in the test plan, regardless of type and speed.
Story Points: ---
Clone Of: 1024499
Environment:
Last Closed: 2014-05-21 15:19:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2013-11-20 10:26:02 EST
+++ This bug was initially created as a clone of Bug #1024499 +++

Description of problem:

It would be great if you could run all the new network tests via:

hwcert-backend run --tag network

and all the usb tests:

hwcert-backend run --tag usb

etc.


Version-Release number of selected component (if applicable):

hwcert-client 1.7.0

--- Additional comment from Greg Nichols on 2013-11-20 10:15:35 EST ---

With this patch, tests can be run via general categories for tests that have been broken down into specific test types.   For example, to run all network tests, the following command line can be used:

>hwcert-backend run --tag network

This will run any of the rate-specific network tests (1GigEthernet, 10GigEthernet, WirelessG).

Similarly, to run any USB-related test use:

>hwcert-backend run --tag usb

And for wlan:

>hwcert-backend run --tag wlan
Comment 4 errata-xmlrpc 2014-05-21 15:19:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0532.html

Note You need to log in before you can comment on or make changes to this bug.