Bug 1032704 - AttributeError: 'DiskLabel' object has no attribute 'peStart'
AttributeError: 'DiskLabel' object has no attribute 'peStart'
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:13a39133a346fa10c3f0bd57568...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 10:39 EST by Peter Kotvan
Modified: 2013-12-16 14:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 14:32:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (290.09 KB, text/plain)
2013-11-20 10:39 EST, Peter Kotvan
no flags Details
File: anaconda.log (6.80 KB, text/plain)
2013-11-20 10:39 EST, Peter Kotvan
no flags Details
File: environ (405 bytes, text/plain)
2013-11-20 10:39 EST, Peter Kotvan
no flags Details
File: ks.cfg (698 bytes, text/plain)
2013-11-20 10:39 EST, Peter Kotvan
no flags Details
File: lsblk_output (1.30 KB, text/plain)
2013-11-20 10:39 EST, Peter Kotvan
no flags Details
File: nmcli_dev_list (455 bytes, text/plain)
2013-11-20 10:39 EST, Peter Kotvan
no flags Details
File: os_info (397 bytes, text/plain)
2013-11-20 10:39 EST, Peter Kotvan
no flags Details
File: program.log (21.24 KB, text/plain)
2013-11-20 10:40 EST, Peter Kotvan
no flags Details
File: storage.log (44.64 KB, text/plain)
2013-11-20 10:40 EST, Peter Kotvan
no flags Details
File: syslog (65.65 KB, text/plain)
2013-11-20 10:40 EST, Peter Kotvan
no flags Details
File: ifcfg.log (4.46 KB, text/plain)
2013-11-20 10:40 EST, Peter Kotvan
no flags Details
File: packaging.log (11.31 KB, text/plain)
2013-11-20 10:40 EST, Peter Kotvan
no flags Details

  None (edit)
Description Peter Kotvan 2013-11-20 10:39:20 EST
Description of problem:
On system with two hard disks tried to install with kickstart (install / to logical volume on raw device)

Version-Release number of selected component:
anaconda-19.31.34-1

The following was filed automatically by anaconda:
anaconda 19.31.34-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2410, in size
    size += max(0, self.align(pv.size - pv.format.peStart))
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 514, in __str__
    s = "%s %dMB %s" % (exist, self.size, super(StorageDevice, self).__str__())
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2107, in getDeviceByName
    log_method_return(self, str(found))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 709, in execute
    vg = devicetree.getDeviceByName(vgname)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 673, in execute
    l.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1735, in doKickstartStorage
    ksdata.logvol.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 402, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'DiskLabel' object has no attribute 'peStart'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=RHEL-7.0\x20x86_64 quiet ks=http://file.brq.redhat.com/~pkotvan/ks/raw-lvm BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-50.el7.x86_64
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)
type:           anaconda
version:        7.0
Comment 1 Peter Kotvan 2013-11-20 10:39:24 EST
Created attachment 826712 [details]
File: anaconda-tb
Comment 2 Peter Kotvan 2013-11-20 10:39:32 EST
Created attachment 826713 [details]
File: anaconda.log
Comment 3 Peter Kotvan 2013-11-20 10:39:39 EST
Created attachment 826714 [details]
File: environ
Comment 4 Peter Kotvan 2013-11-20 10:39:47 EST
Created attachment 826715 [details]
File: ks.cfg
Comment 5 Peter Kotvan 2013-11-20 10:39:50 EST
Created attachment 826716 [details]
File: lsblk_output
Comment 6 Peter Kotvan 2013-11-20 10:39:54 EST
Created attachment 826717 [details]
File: nmcli_dev_list
Comment 7 Peter Kotvan 2013-11-20 10:39:58 EST
Created attachment 826718 [details]
File: os_info
Comment 8 Peter Kotvan 2013-11-20 10:40:02 EST
Created attachment 826719 [details]
File: program.log
Comment 9 Peter Kotvan 2013-11-20 10:40:05 EST
Created attachment 826720 [details]
File: storage.log
Comment 10 Peter Kotvan 2013-11-20 10:40:09 EST
Created attachment 826721 [details]
File: syslog
Comment 11 Peter Kotvan 2013-11-20 10:40:12 EST
Created attachment 826722 [details]
File: ifcfg.log
Comment 12 Peter Kotvan 2013-11-20 10:40:16 EST
Created attachment 826723 [details]
File: packaging.log
Comment 14 David Cantrell 2013-12-16 14:32:31 EST
Unable to reproduce this problem on RHEL 7.0 Beta.

Note You need to log in before you can comment on or make changes to this bug.