Bug 1032720 - virt-manager allocates huge amount of ram when using http install
virt-manager allocates huge amount of ram when using http install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 11:30 EST by Tomas Dolezal
Modified: 2015-06-19 04:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-19 04:33:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pmap -xp (79.77 KB, text/plain)
2013-11-20 11:30 EST, Tomas Dolezal
no flags Details

  None (edit)
Description Tomas Dolezal 2013-11-20 11:30:55 EST
Created attachment 826736 [details]
pmap -xp

Description of problem:
virt-manager allocates over 1.5GiB of virtual memory after two or more virtual machines are created: Network install (http), ram 1800MB, storage LVM lv
guest os: rhel-7 "latest"

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-7.el7.noarch
python-2.7.5-10.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. choose network install
2. specify http URL (rhel-7 in my case)
3. set RAM 1800MB
4. I've used LVM
5. install os, don't turn it off, remove it (without disk if you want)
6. repeat at least once (with disk from step 5 if you have it)

Actual results:
virt-manager uses over 1.5GiB of virtual memory

Expected results:
considerably lower memory consumption

Additional info:
VM specs after installation:
  ...
  <memory unit='KiB'>1843200</memory>
  <currentMemory unit='KiB'>1843200</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <os>
    <type arch='x86_64' machine='pc-i440fx-rhel7.0.0'>hvm</type>
    <boot dev='hd'/>
  </os>
  ...
Comment 3 tingting zheng 2014-01-06 06:01:23 EST
I can reproduce this issue with:
virt-manager-0.10.0-8.el7.noarch.

Steps are the same as description.
Comment 5 Giuseppe Scrivano 2014-09-08 05:31:45 EDT
*** Bug 1139125 has been marked as a duplicate of this bug. ***
Comment 6 Giuseppe Scrivano 2014-11-13 05:12:48 EST
can it still be reproduced on RHEL-7.1 with the latest pygobject version? I am going to move it to 7.2
Comment 8 Pavel Hrdina 2015-06-19 04:27:54 EDT
Since there were no response, whether the issue is still there and I've tested it right now and the memory usage by virt-manager after several network install is consistent, I'm closing this bug as fixed by rebase.

One more thing to add, the usage of virtual memory will be always significantly larger, because it contains all shared libraries.  The RES (Resident Memory Size) is the value you should check, because that's the current memory usage.
Comment 9 Pavel Hrdina 2015-06-19 04:33:22 EDT
I've just looked at the attachment and actually this wasn't bug at all, because the real usage is about 216 MiB, which isn't that much.  I'm closing this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.