Bug 1032785 - [abrt] virt-viewer-0.5.6-8.el6: pa_stream_is_corked: Process /usr/bin/remote-viewer was killed by signal 6 (SIGABRT)
[abrt] virt-viewer-0.5.6-8.el6: pa_stream_is_corked: Process /usr/bin/remote-...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.6
x86_64 Unspecified
high Severity high
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
abrt_hash:a5cf331b88ab5735a07da4ab013...
: ZStream
Depends On:
Blocks: 1090000
  Show dependency treegraph
 
Reported: 2013-11-20 15:23 EST by David Jaša
Modified: 2014-10-14 02:46 EDT (History)
12 users (show)

See Also:
Fixed In Version: spice-gtk-0.22-1.el6
Doc Type: Bug Fix
Doc Text:
*no doc required*
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (49.43 KB, text/plain)
2013-11-20 15:23 EST, David Jaša
no flags Details
File: var_log_messages (155 bytes, text/plain)
2013-11-20 15:23 EST, David Jaša
no flags Details
File: open_fds (1.73 KB, text/plain)
2013-11-20 15:23 EST, David Jaša
no flags Details
File: environ (2.41 KB, text/plain)
2013-11-20 15:23 EST, David Jaša
no flags Details
File: dso_list (11.22 KB, text/plain)
2013-11-20 15:23 EST, David Jaša
no flags Details
File: sosreport.tar.xz (3.37 MB, application/octet-stream)
2013-11-20 15:24 EST, David Jaša
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-20 15:24 EST, David Jaša
no flags Details
File: last_occurrence (10 bytes, text/plain)
2013-11-20 15:24 EST, David Jaša
no flags Details
File: backtrace (20.51 KB, text/plain)
2013-11-20 15:24 EST, David Jaša
no flags Details
File: cgroup (88 bytes, text/plain)
2013-11-20 15:24 EST, David Jaša
no flags Details

  None (edit)
Description David Jaša 2013-11-20 15:23:34 EST
Description of problem:
remote-viewer crashed when fiddling with volume in youtube html5 player after pulseaudio restart. I didn't reproduce the crash at subsequent attempts though.

Version-Release number of selected component:
virt-viewer-0.5.6-8.el6

Additional info:
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        remote-viewer --spice-controller
crash_function: pa_stream_is_corked
kernel:         2.6.32-420.el6.x86_64

truncated backtrace:
:Thread no. 1 (9 frames)
: #2 pa_stream_is_corked at pulse/stream.c
: #3 stream_cork at spice-pulse.c
: #4 playback_min_latency_changed at spice-pulse.c
: #9 g_object_dispatch_properties_changed at gobject.c
: #10 g_object_notify_queue_thaw at gobjectnotifyqueue.c
: #11 g_object_notify_by_spec_internal at gobject.c
: #12 g_object_notify at gobject.c
: #13 notify_main_context at gio-coroutine.c
: #18 IA__gtk_main at gtkmain.c
Comment 1 David Jaša 2013-11-20 15:23:40 EST
Created attachment 826832 [details]
File: maps
Comment 2 David Jaša 2013-11-20 15:23:44 EST
Created attachment 826833 [details]
File: var_log_messages
Comment 3 David Jaša 2013-11-20 15:23:48 EST
Created attachment 826834 [details]
File: open_fds
Comment 4 David Jaša 2013-11-20 15:23:52 EST
Created attachment 826835 [details]
File: environ
Comment 5 David Jaša 2013-11-20 15:23:57 EST
Created attachment 826836 [details]
File: dso_list
Comment 6 David Jaša 2013-11-20 15:24:26 EST
Created attachment 826837 [details]
File: sosreport.tar.xz
Comment 7 David Jaša 2013-11-20 15:24:36 EST
Created attachment 826838 [details]
File: limits
Comment 8 David Jaša 2013-11-20 15:24:41 EST
Created attachment 826839 [details]
File: last_occurrence
Comment 9 David Jaša 2013-11-20 15:24:45 EST
Created attachment 826840 [details]
File: backtrace
Comment 10 David Jaša 2013-11-20 15:24:49 EST
Created attachment 826841 [details]
File: cgroup
Comment 12 RHEL Product and Program Management 2013-11-24 03:31:49 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 13 Marc-Andre Lureau 2013-11-25 07:34:27 EST
patch on ML
http://lists.freedesktop.org/archives/spice-devel/2013-November/015573.html
Comment 14 Marc-Andre Lureau 2014-04-16 09:29:43 EDT
zstream update?
Comment 18 errata-xmlrpc 2014-10-14 02:46:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1487.html

Note You need to log in before you can comment on or make changes to this bug.