Bug 1032789 - Honour all schema locations setting is not disabled when creating a new project
Honour all schema locations setting is not disabled when creating a new project
Status: CLOSED WONTFIX
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard Editor (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rob Cernich
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 15:37 EST by Rob Cernich
Modified: 2015-08-02 19:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The "Honour all schema locations" setting is not disabled when the user creates a new project in the SwitchYard Editor. This occurs if the project was created using a version that cannot be resolved from any configured Maven repositories. If the version specified in the wizard can be located, the preference is disabled appropriately. The user will encounter XML errors. To work around this fix the version and update the project, as this will install the SwitchYard facet, which will disable the XML validation setting.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-02 14:27:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1837 Major Closed Honour all schema locations setting is not disabled when creating a new project 2016-06-29 18:06 EDT

  None (edit)
Description Rob Cernich 2013-11-20 15:37:20 EST
In a new workspace, create a SwitchYard project and add a bean component. Save the editor. Notice xml errors consistent with honour all schema locations property being enabled.

I suspect something may not be getting invoked properly when creating a new project. I found this while I was walking through the tooling tutorial in the documentation.
Comment 1 JBoss JIRA Server 2013-11-21 13:41:16 EST
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1837

This only occurs if the project was created using a version that cannot be resolved from any configured maven repositories.  If the version specified in the wizard can be located, the preference is disabled appropriately.

The fix for this is probably more involved as it looks like the SwitchYard facet is not installed if this is the case (which is why the preference isn't updated).  I'm not sure if there's any way for us to detect this and update the project accordingly.  The user may have to use Maven->update project to fix the problem.

Moving to 2.0
Comment 2 JBoss JIRA Server 2013-12-03 15:17:46 EST
Rob Cernich <rcernich@redhat.com> updated the status of jira SWITCHYARD-1837 to Resolved
Comment 3 JBoss JIRA Server 2013-12-03 15:17:46 EST
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1837

Seeing as the project fails to be detected as a SwitchYard project, I don't think this is critical.  Fixing the version and updating the project will install the SwitchYard facet, which will disable the xml validation setting.
Comment 4 kconner 2014-08-14 20:32:42 EDT
Dependent on upgrading tooling to JBDS 8
Comment 5 JBoss JIRA Server 2014-11-03 09:34:23 EST
Andrej Podhradsky <apodhrad@redhat.com> updated the status of jira SWITCHYARD-1837 to Closed

Note You need to log in before you can comment on or make changes to this bug.