Bug 1032843 - nova.conf references ubuntu template
nova.conf references ubuntu template
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 4.0
Assigned To: Francesco Vollero
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 20:48 EST by Summer Long
Modified: 2013-11-26 13:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 13:46:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Summer Long 2013-11-20 20:48:17 EST
Description of problem:
The nova.conf file contains the following template reference after creation:
# Template file for injected network config (string value)
#net_config_template=$pybasedir/nova/virt/baremetal/net-dhcp.ubuntu.template


Version-Release number of selected component (if applicable):
openstack-packstack.noarch 2013.2.1-0.11.dev806.el6

How reproducible:
After installation, look at the /etc/nova/nova.conf file.


Actual results:
Refers to an Ubuntu template.

Expected results:
Should refer to a RHOS template. 

Additional info:
Comment 2 Francesco Vollero 2013-11-25 13:46:10 EST
This is not a bug within packstack but in nova upstream, so need to be fixed (renaming the file) there.
Comment 3 Summer Long 2013-11-25 19:17:44 EST
Ok, thanks for looking at it. Will raise a task upstream.
Comment 4 Summer Long 2013-11-25 20:10:55 EST
Raised this: https://bugs.launchpad.net/nova/+bug/1254933

Note You need to log in before you can comment on or make changes to this bug.