Bug 103285 - (xterm) xterm upgrade fails with cpio errors
xterm upgrade fails with cpio errors
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: xterm (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 103372 103644 103673 103774 103795 103915 104308 106203 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 11:25 EDT by Chris Ricker
Modified: 2007-04-18 12:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-30 02:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-08-28 11:25:00 EDT
I get the following trying to install the latest xterm RPM (xterm-179-4.1.i386.rpm)

xterm 100 % done 
error: unpacking of archive failed on file /usr/X11R6/bin/xterm: cpio: rename

This was an attempt to upgrade from xterm-179-3
Comment 1 Chris Ricker 2003-08-28 11:27:29 EDT
Uninstalling xterm-179-3 and then installing xterm-179-4.1 works

I don't think xterm-179-3 was added until this beta, so changing priority....
Comment 2 Nils Philippsen 2003-08-28 11:33:55 EDT
This is because the normal file /usr/X11R6/bin/xterm gets replaced by
/usr/bin/xterm and a symlink pointing to it (from the old location). RPM doesn't
yet handle this gracefully, so I'd advise to either put some "magic" in a %pre
script or leave xterm at the old location.

If this is not changed (one way or the other), it will bite users, regardless of
xterm being in a separate package or not -> bumped severity back to "normal".
Comment 3 Bill Nottingham 2003-08-28 15:19:49 EDT
Remove the old broken xterm package before upgrading is the solution for this.
RPM will handle replacing the file fine on upgrades from previous OS releases;
it's just that the -3 pacakge was broken and replaced /usr/X11R6/bin/xterm with
a directory with the symlink insidfe it.
Comment 4 Bill Nottingham 2003-08-29 10:34:23 EDT
*** Bug 103372 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2003-08-30 02:27:00 EDT
I'm reopening this and closing it as RAWHIDE, because the problem is fixed
in rawhide, however the fix requires one to manually uninstall the prior
xterm package first.  It's one of those type of bugs that we can't really
"fix" fix, due to the nature of the bug and the fact that rpm has a limitation
that can't replace a directory with a symlink as noted above.  I've changed
the resolution to RAWHIDE with the stipulation of manual uninstallation
being needed, as I think it's better than "WONTFIX".

Comment 6 Bill Nottingham 2003-09-03 12:16:48 EDT
*** Bug 103644 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2003-09-03 15:29:35 EDT
*** Bug 103673 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2003-09-04 17:32:25 EDT
*** Bug 103774 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2003-09-04 21:09:11 EDT
*** Bug 103795 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2003-09-07 23:53:08 EDT
*** Bug 103915 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2003-09-12 12:50:15 EDT
*** Bug 104308 has been marked as a duplicate of this bug. ***
Comment 12 Mike A. Harris 2003-10-03 13:22:39 EDT
*** Bug 106203 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.