Bug 103290 - OOo dumps core when using ODBC to access a PostgreSQL db
OOo dumps core when using ODBC to access a PostgreSQL db
Status: CLOSED ERRATA
Product: Red Hat Linux Beta
Classification: Retired
Component: openoffice.org (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 11:53 EDT by Chris Ricker
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 08:12:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-08-28 11:53:57 EDT
When using unixODBC to access a PostgreSQL db on severn, I reliably get
coredumps from OOo

Is there a debug package I can install to get the backtrace?

At any rate, the crashes seem to come reliably simply by switching between tabs
in the Data Source Administration tool. Once the database was defined, any
further use of the Data Source Administration tool seems to trigger a core dump.
Most of the time, they come when I switch from the General tab to the Tables tab
Comment 1 Charles Curley 2003-09-25 13:34:34 EDT
OpenOffice works fine when connecting to MySQL via unixODBC. See John McCreesh,
"OpenOffice.org 1.0, ODBC, and MySQL 'How-to'" at
http://www.unixodbc.org/doc/OOoMySQL.pdf. However, unixODBC (unixODBC-2.2.2-3)
includes a command line tool, isql. It also crashes when attempting to access a
pgsql data source, which leads me to think that this is a unixODBC issue, rather
than an OpenOffice issue. I see this in OOo 1.0.3a and in 1.1 RC 4.
Comment 2 Chris Ricker 2003-09-25 13:44:29 EDT
Naw, unixODBC works fine with postgres once configured properly. The
out-of-the-box RH config is borked (see Bug #103280), but when you fix that
unixODBC -> postgres is fine in general, isql works, etc.

Even with all that, though, OO -> unixODBC -> postgres crashes and burns
regularly for me though
Comment 3 Chris Ricker 2003-10-15 19:03:59 EDT
I'm still seeing this with 1.1. OOo -> unixODBC -> PostgreSQL dies when doing
any sort of table viewing
Comment 4 Chris Ricker 2003-10-15 19:08:25 EDT
The bt, though it doesn't look useful, is:

#0  0x006adc32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x006ec98f in raise () from /lib/tls/libc.so.6
#2  0x006ee302 in abort () from /lib/tls/libc.so.6
#3  0x0049cb42 in CallSystemHandler ()
   from /usr/lib/openoffice/program/libsal.so.3
#4  0x0049cc06 in SignalHandlerFunction ()
   from /usr/lib/openoffice/program/libsal.so.3
#5  <signal handler called>
Comment 5 Dan Williams 2003-10-31 14:02:12 EST
Chris, is this in any way related to Bug #107551 ?  Does it work when
you do View->Data Sources but not Tools->Data Sources?
Comment 6 Chris Ricker 2003-11-04 00:26:12 EST
Both View -> Data Sources and Tools -> Data Sources die when I try to
view the tables in a postgresql db I'm hitting over unixODBC

Not sure if it's like Bug #107551 or not. I die either way, and with
postgres. He dies only Tools -> Data, but with mysql....
Comment 7 Dan Williams 2004-02-27 11:41:06 EST
Please try current OOo 1.1.0, and reopen if problem still occurs
Comment 8 Chris Ricker 2004-03-01 13:55:33 EST
Current as in rawhide, or as in shipped / updates Fedora Core 1?

postgresql-7.3.4-11
unixODBC-2.2.5-9
openoffice.org-1.1.0-6

Still crashes for me under Views -> Data or Tools -> Data
Comment 9 Tom Lane 2004-03-05 13:03:04 EST
Guys, this may be a dupe of bug #110595.  Would you check if it is
fixed in FC2 devel?
Comment 10 Caolan McNamara 2004-10-28 08:12:49 EDT
caolanm->Chris Ricker: Can you try with a unixODBC >= 2.2.8, and if
still no success reopen again. I strongly suspect #110595 as tgl says.

Note You need to log in before you can comment on or make changes to this bug.