Bug 1032956 - BPEL Console - can't log in in Windows
BPEL Console - can't log in in Windows
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: BPEL Integration (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER8
: 6.0.0
Assigned To: kconner
lvaskova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 04:57 EST by lvaskova
Modified: 2014-02-06 10:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lvaskova 2013-11-21 04:57:47 EST
Description of problem:

Can't log in to BPEL console in Windows using correct username and password. I've tried Chrome and Firefox browser. (IE9 has another issue: bug 1032947)

How reproducible:
every time

Steps to Reproduce:
1. run server
2. go to: http://localhost:8080/bpel-console (use Chrome or Firefox)
3. try to log in - problem will appear: "Authentication failed. Please try again"
Comment 1 lvaskova 2013-11-21 09:43:03 EST
Same issue on: Windows Server Enterprise 2003 - Internet Explorer 8
Comment 2 Eric Wittmann 2013-11-21 14:05:30 EST
What build of FSW6 are you using to test this?  Beta?
Comment 3 Eric Wittmann 2013-11-21 15:25:01 EST
This appears to be a problem with the installer.  I downloaded the beta from jboss.org/products and tested it on Windows 8.1.  The installer failed to put the "bpel credentials" in the standalone/configuration/application-*.properties files.  Once I added a user via the 'add-user.sh' script (application realm) I was able to log into the BPEL console successfully.

Since the beta is already out, and we have changed how authentication works for the GA release, I think this BZ should be closed.

Assigning to kconner for review. :)
Comment 4 kconner 2013-12-16 13:33:23 EST
Tom has verified that this is fixed in the installer.  He tested the ER7-2 installer and could successfully log in to the bpel console using fswAdmin.
Comment 5 lvaskova 2013-12-21 05:55:48 EST
Verified on ER7

Note You need to log in before you can comment on or make changes to this bug.