Bug 1032959 - Evolution doesn't follow first-time account setup wizard settings
Evolution doesn't follow first-time account setup wizard settings
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 05:05 EST by Matěj Cepl
Modified: 2014-01-24 04:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-24 03:05:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dialog box (45.69 KB, image/png)
2014-01-23 12:51 EST, Matěj Cepl
no flags Details
detailed information about the certificate (63.86 KB, image/png)
2014-01-23 12:52 EST, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2013-11-21 05:05:44 EST
Description of problem:
In order to finally make Evolution work, I have removed completely ~/.config/evolution, ~/.cache/evolution, and ~/.local/share/evolution, and restarted evolution. I got the first-time-run account setup wizard and after setting up the Red Hat email account (and expressly checking for availability and selecting GSSAPI as the method of authentication), and finishing the wizard, finally the full Evo window was visible.

Except that, it won't let me go further without entering password. After entering it, I found that the mail account had set password set up as a the mean of authentication.

Version-Release number of selected component (if applicable):
evolution-3.8.5-10.el7.x86_64

How reproducible:
happened once
Comment 2 Milan Crha 2014-01-14 08:21:19 EST
Thanks for a bug report. I cannot reproduce this, the GSSAPI stick for me from the startup wizard. I have 3.8.5-11, but the -11 didn't bring anything significant. Evolution-data-server is 3.8.5-10.
Comment 3 Milan Crha 2014-01-23 08:46:24 EST
Could you retest with more recent packages, please?
Comment 4 Matěj Cepl 2014-01-23 12:51:22 EST
Created attachment 854518 [details]
dialog box

(In reply to Milan Crha from comment #3)
> Could you retest with more recent packages, please?

The issue of this bug report has been apparently resolved (after running the first run wizard, I get correctly GSSAPI authentication), but another issue arised: when recovering (both via File/Recovery or by unzipping zipfile with ~/.config/evolution/ ~/.cache/evolution/ ~/.local/share/evolution/) Evolution gets confused and claims that my personal IMAP server has unknown certificate (see attached screenshot). Which is weird, because I have actually purchased commercial certificate from StartCom which should be atuomatically recognized by NSS/OpenSSL/whatever else we have in RHEL (and it works perfectly well with Firefox OS Email, which doesn't allow self-signed certificates).

Should I file a new bug or it is known?
Comment 5 Matěj Cepl 2014-01-23 12:52:07 EST
Created attachment 854519 [details]
detailed information about the certificate
Comment 6 Milan Crha 2014-01-24 03:05:41 EST
It is what libsoup returned when trying to connect to the server. I'm not sure which certificate authority database is used in libsoup, I think it uses gnutls instead of nss/nspr for this, which may or may not make the difference.
The CalDAV calendar backend only sets
   SOUP_SESSION_SSL_STRICT, TRUE,
   SOUP_SESSION_SSL_USE_SYSTEM_CA_FILE, TRUE,
on the soup's session.

It'll be better to deal with this in a separate bug report, I would even start with libsoup, at least for a clarification where it searches for certificate authorities and so on.
Comment 7 Matěj Cepl 2014-01-24 04:18:56 EST
(In reply to Milan Crha from comment #6)
> It'll be better to deal with this in a separate bug report, I would even
> start with libsoup, at least for a clarification where it searches for
> certificate authorities and so on.

Filed as bug 1057509

Note You need to log in before you can comment on or make changes to this bug.