Bug 1032991 - Zanata shows wrong validation warnings
Zanata shows wrong validation warnings
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Performance (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 06:25 EST by Shankar Prasad
Modified: 2015-04-21 00:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 02:18:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Wrong validation warning (124.86 KB, image/png)
2013-11-21 06:25 EST, Shankar Prasad
no flags Details

  None (edit)
Description Shankar Prasad 2013-11-21 06:25:05 EST
Created attachment 827133 [details]
Wrong validation warning

Description of problem:
The zanata wrongly shows up the validation error for a string in ABRT.

Version-Release number of selected component (if applicable):
3.1.2

How reproducible:
Every time

Steps to Reproduce:
1. Authenticate yourself via kinit 

2. Go to, https://translate.engineering.redhat.com/webtrans/translate?project=abrt&iteration=2.1.7&localeId=kn&locale=en#view:doc;doc:abrt;untranslated:show;fuzzy:show;rejected:show

2. click on 'Login'

3. Go to the #91 and check the validation warning displayed 

Actual results:
Wrongly showing the warning

Expected results:
There should not be any warning/error messages


Additional info:
Please refer the attached screenshot
Comment 1 Alex Eng 2013-11-21 16:19:38 EST
Hi Shankar, 
The problem is that "Java variables" validation is turned on for this non-Java project(I'm assuming its C from the looks of the source). 

This is something that project maintainers need to manage on the validation options to make sure only the appropriate validations are turn on for their project. They can enforce certain validation options as well to make sure translation can't be saved if there's error. 

This can be done in the project/version settings page. Only project maintainers have access to this option. 

Alternately, translators are free to turn off validations which are not enforced by project maintainers. This can be done in the right side menu of editor, click on the icon with tick symbol.   

From screen shot, the validation message is showing as 'warning' which means
1) This validation (Java variables) is not enforced by maintainers.
2) Translator still can save their translations despite the having validation warning.  

If the warning is such a distraction, please contact the project maintainers to turn off the "Java variables" validation for the project.

Let us know if you need more info.
Comment 2 Ding-Yi Chen 2014-03-26 02:18:54 EDT
As comment #1 works, I hereby close it as NOTABUG.
However, we might plan to file an RFE for setting the validation warning respecting the computer language.

Note You need to log in before you can comment on or make changes to this bug.