Bug 1033028 - Prevent users entering empty program group for shortcuts.
Prevent users entering empty program group for shortcuts.
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ER1
: EAP 6.3.0
Assigned To: Miles Tjandrawidjaja
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 07:53 EST by Petr Kremensky
Modified: 2014-09-03 00:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:27:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-11-21 07:53:21 EST
Description of problem:
 Users shouldn't be able to enter "" as the Program group name for shortcuts.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.CR2

How reproducible:
 Always

Steps to Reproduce:
 1. Go to shortcuts creation screen using default values.
 2. Eneter "" as Program group name.
 3. Press the Next button.

Actual results:
 User can finish the installation.

Expected results:
 Error dialog is thrown.

Additional info:
 Cannot try this on windows, as we don't have any free host in lab now.
Comment 1 Miles Tjandrawidjaja 2013-11-22 10:58:48 EST
Hello,

Tried this on Fedora 18 and the program group "" was created.
When I tried on Windows 7 I couldn't find the shortcuts.

Should we just constrain the program group to contains only alphanumeric characters?
Comment 2 Petr Kremensky 2013-11-25 01:29:37 EST
Yes, this should be enough.
Comment 3 Miles Tjandrawidjaja 2013-11-25 14:47:01 EST
Added validation for program group to be alpha-numeric.

http://git.app.eng.bos.redhat.com/izpack.git/commit/?h=izpack-wip&id=11744a383e123902a26cd4ecac5da7c399317133
Comment 4 Petr Kremensky 2014-04-17 02:41:11 EDT
Verified on EAP 6.3.0.ER1.

Note You need to log in before you can comment on or make changes to this bug.