Bug 1033052 - Unresolved dependency in openscap-workbench
Unresolved dependency in openscap-workbench
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scap-workbench (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Martin Preisler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 08:31 EST by Russell Doty
Modified: 2014-06-11 08:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-11 08:57:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2013-11-21 08:31:10 EST
# yum install scap-workbench
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package scap-workbench.x86_64 0:0.8.1-1.fc20 will be installed
--> Processing Dependency: libopenscap.so.3()(64bit) for package: scap-workbench-0.8.1-1.fc20.x86_64
--> Processing Dependency: libQtWebKit.so.4()(64bit) for package: scap-workbench-0.8.1-1.fc20.x86_64
--> Processing Dependency: libQtGui.so.4()(64bit) for package: scap-workbench-0.8.1-1.fc20.x86_64
--> Processing Dependency: libQtCore.so.4()(64bit) for package: scap-workbench-0.8.1-1.fc20.x86_64
--> Running transaction check
---> Package qt.x86_64 1:4.8.5-10.fc20 will be installed
--> Processing Dependency: qt-settings for package: 1:qt-4.8.5-10.fc20.x86_64
---> Package qt-x11.x86_64 1:4.8.5-10.fc20 will be installed
--> Processing Dependency: libmng.so.1()(64bit) for package: 1:qt-x11-4.8.5-10.fc20.x86_64
---> Package qtwebkit.x86_64 0:2.3.3-1.fc20 will be installed
--> Processing Dependency: libQtSensors.so.1()(64bit) for package: qtwebkit-2.3.3-1.fc20.x86_64
--> Processing Dependency: libQtLocation.so.1()(64bit) for package: qtwebkit-2.3.3-1.fc20.x86_64
---> Package scap-workbench.x86_64 0:0.8.1-1.fc20 will be installed
--> Processing Dependency: libopenscap.so.3()(64bit) for package: scap-workbench-0.8.1-1.fc20.x86_64
--> Running transaction check
---> Package libmng.x86_64 0:1.0.10-12.fc20 will be installed
---> Package qt-mobility.x86_64 0:1.2.2-0.5.20120224git.fc20 will be installed
---> Package qt-settings.noarch 0:20-7.fc20 will be installed
---> Package scap-workbench.x86_64 0:0.8.1-1.fc20 will be installed
--> Processing Dependency: libopenscap.so.3()(64bit) for package: scap-workbench-0.8.1-1.fc20.x86_64
--> Finished Dependency Resolution
Error: Package: scap-workbench-0.8.1-1.fc20.x86_64 (fedora)
           Requires: libopenscap.so.3()(64bit)
           Available: openscap-0.9.12-2.fc20.x86_64 (fedora)
               libopenscap.so.3()(64bit)
           Installed: openscap-1.0.0-1.fc20.x86_64 (@updates-testing)
              ~libopenscap.so.8()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 George R. Goffe 2013-12-04 10:14:26 EST
Martin,

Is this problem below part of this current bug by any chance? I did, basically, a yum update on my fc 19 x86-64 system and got a bunch of error messages.

Sorry to bother you if these messages are unrelated.

George...


yum repository-packages updates update
Loaded plugins: aliases, auto-update-debuginfo, changelog, fastestmirror, filter-data, fs-snapshot, keys, langpacks, list-data, local, merge-conf, post-
              : transaction-actions, priorities, protectbase, ps, puppetverify, refresh-packagekit, refresh-updatesd, remove-with-leaves, rpm-warm-cache,
              : show-leaves, tmprepo, tsflags, upgrade-helper, verify, versionlock
Loading mirror speeds from cached hostfile
 * fedora: linux.mirrors.es.net
 * fedora-debuginfo: linux.mirrors.es.net
 * updates: linux.mirrors.es.net
 * updates-debuginfo: linux.mirrors.es.net
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package openscap.x86_64 0:0.9.12-1.fc19 will be updated
---> Package openscap.x86_64 0:1.0.0-2.fc19 will be an update
--> Processing Dependency: openscap-engine-sce = 1.0.0-2.fc19 for package: openscap-1.0.0-2.fc19.x86_64
---> Package openscap-content.noarch 0:0.9.12-1.fc19 will be obsoleted
--> Processing Dependency: openscap-content >= 0.7.2 for package: firstaidkit-plugin-openscap-0.3.2-6.fc19.noarch
---> Package openscap-python.x86_64 0:0.9.12-1.fc19 will be updated
---> Package openscap-python.x86_64 0:1.0.0-2.fc19 will be an update
---> Package openscap-utils.x86_64 0:0.9.12-1.fc19 will be updated
---> Package openscap-utils.x86_64 0:1.0.0-2.fc19 will be an update
---> Package scap-security-guide.noarch 0:0.1-3.1.fc19 will be obsoleting
--> Running transaction check
---> Package openscap-content.noarch 0:0.9.12-1.fc19 will be obsoleted
--> Processing Dependency: openscap-content >= 0.7.2 for package: firstaidkit-plugin-openscap-0.3.2-6.fc19.noarch
---> Package openscap-engine-sce.x86_64 0:1.0.0-2.fc19 will be installed
--> Finished Dependency Resolution
Error: Package: firstaidkit-plugin-openscap-0.3.2-6.fc19.noarch (@fedora)
           Requires: openscap-content >= 0.7.2
           Removing: openscap-content-0.9.12-1.fc19.noarch (@updates)
               openscap-content = 0.9.12-1.fc19
           Obsoleted By: scap-security-guide-0.1-3.1.fc19.noarch (updates)
               Not found
           Available: openscap-content-0.9.7-1.fc19.noarch (fedora)
               openscap-content = 0.9.7-1.fc19
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
gtkd-devel-2.0.0-42.20130624gitdb5921d.fc19.x86_64 has missing requires of gtkd(x86-64) = ('0', '2.0.0', '42.20130624gitdb5921d.fc19')
gtkd-devel-2.0.0-42.20130624gitdb5921d.fc19.x86_64 has missing requires of libgtkd-2.so.0()(64bit)
gtkd-devel-2.0.0-42.20130624gitdb5921d.fc19.x86_64 has missing requires of libgtkdgl-2.so.0()(64bit)
gtkd-devel-2.0.0-42.20130624gitdb5921d.fc19.x86_64 has missing requires of libgtkdsv-2.so.0()(64bit)
gtkd-geany-tags-2.0.0-42.20130624gitdb5921d.fc19.noarch has missing requires of gtkd = ('0', '2.0.0', '42.20130624gitdb5921d.fc19')
Comment 2 Martin Preisler 2013-12-04 10:54:23 EST
Hi, the dependency situation was caused by openscap bumping soname. There were some issues with the openscap release which took time to resolve.

After this update gets into stable everything should once again run smoothly.

https://admin.fedoraproject.org/updates/FEDORA-2013-22093/scap-security-guide-0.1-3.1.fc20,openscap-1.0.0-2.fc20,scap-workbench-0.8.2-2.fc20

Sorry for the inconvenience.
Comment 3 Martin Preisler 2013-12-04 10:57:13 EST
(In reply to George R. Goffe from comment #1)
> [snip]
> Error: Package: firstaidkit-plugin-openscap-0.3.2-6.fc19.noarch (@fedora)
>            Requires: openscap-content >= 0.7.2
>            Removing: openscap-content-0.9.12-1.fc19.noarch (@updates)
>                openscap-content = 0.9.12-1.fc19
>            Obsoleted By: scap-security-guide-0.1-3.1.fc19.noarch (updates)
>                Not found
>            Available: openscap-content-0.9.7-1.fc19.noarch (fedora)
>                openscap-content = 0.9.7-1.fc19
>  You could try using --skip-broken to work around the problem

The problem is caused by firstaidkit-plugin-openscap requiring openscap-content of at least 0.7.2 version. openscap-content is no longer a subpackage of openscap. Since firstaidkit-plugin-openscap is orphaned I recommend you to uninstall it to work around this issue.
Comment 4 Ryan 2013-12-10 22:58:48 EST
(In reply to Martin Preisler from comment #3)
> (In reply to George R. Goffe from comment #1)
> > [snip]
> > Error: Package: firstaidkit-plugin-openscap-0.3.2-6.fc19.noarch (@fedora)
> >            Requires: openscap-content >= 0.7.2
> >            Removing: openscap-content-0.9.12-1.fc19.noarch (@updates)
> >                openscap-content = 0.9.12-1.fc19
> >            Obsoleted By: scap-security-guide-0.1-3.1.fc19.noarch (updates)
> >                Not found
> >            Available: openscap-content-0.9.7-1.fc19.noarch (fedora)
> >                openscap-content = 0.9.7-1.fc19
> >  You could try using --skip-broken to work around the problem
> 
> The problem is caused by firstaidkit-plugin-openscap requiring
> openscap-content of at least 0.7.2 version. openscap-content is no longer a
> subpackage of openscap. Since firstaidkit-plugin-openscap is orphaned I
> recommend you to uninstall it to work around this issue.

This has rectified the problem for me, thanks Martin
Comment 5 George R. Goffe 2013-12-11 07:15:05 EST
Ryan,

This appears to have solved the problem.

Firstaidkit came with the distribution... and was installed during my installation process. :-(

THANKS for all your help.

George...
Comment 6 George R. Goffe 2013-12-11 07:17:28 EST
Ryan,

Can I ask you a question please?

I was playing with yum the other day and ran a "yum repository-packages install" which apparently tries to install ALL packages in a given repository.

I got a TON of error messages relating to dependencies. Would it be useful for me to open a bug report about this? Would anyone care?

Thanks,

George...
Comment 7 Ryan 2013-12-15 22:26:07 EST
Hi George,

Martin provided the solution, I was thanking him for it in my comment. With regards to the dependancies issue, you would need to identify which dependancies for which packages were causing the problem and then log a bug for each one rather than provide a mass dump of every single one. Or you could just add --skip-broken and ignore the broken dependancies on the particular packages you were having problems with. I'm sure the maintainers would like to know which packages had problems, depending on the repository in question that you were trying to install from...

Ryan

Note You need to log in before you can comment on or make changes to this bug.