Bug 1033113 - [origin_node_331]Failed to build app by git push after deploying by artifact_url
[origin_node_331]Failed to build app by git push after deploying by artifact_url
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
2.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
: 1033766 (view as bug list)
Depends On: 1032950 1033766
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 10:07 EST by Brenton Leanhardt
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version: rubygem-openshift-origin-node-1.17.5-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1032950
Environment:
Last Closed: 2014-01-13 09:54:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-11-21 10:07:47 EST
+++ This bug was initially created as a clone of Bug #1032950 +++

Description of problem:
It's failed to build app by git push after deploying by artifact_url, will meet "Operation not permitted" errors.

Version-Release number of selected component (if applicable):
devenv_4056

How reproducible:
always

Steps to Reproduce:
1. Create an app
rhc app create cphp01 php-5.3
2. Configure deployment type to binary
curl -k -H "Accept: application/xml" --user "chunchen:redhat7" https://ec2-23-22-121-187.compute-1.amazonaws.com/broker/rest/application/528db435e55e7539ba0000be -X PUT -d deployment_type=binary
3. Deploy a binary file by artifact_url
curl -k -H "Accept: application/xml" --user "chunchen:redhat7" https://ec2-23-22-121-187.compute-1.amazonaws.com/broker/rest/application/528db435e55e7539ba0000be/deployments -X POST -d artifact_url=http://cphp-ccyd.rhcloud.com/cphp2.tar.gz
4. Configure deployment type to git
curl -k -H "Accept: application/xml" --user "chunchen:redhat7" https://ec2-23-22-121-187.compute-1.amazonaws.com/broker/rest/application/528db435e55e7539ba0000be -X PUT -d deployment_type=git
5. Do some changes in app local repo
cd cphp01
touch 1.txt
6. Git push the changes
git add .; git commit -amp; git push

Actual results:
[master 83ff058] p
 0 files changed
 create mode 100644 1.txt
Counting objects: 3, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (2/2), 244 bytes, done.
Total 2 (delta 1), reused 0 (delta 0)
remote: Stopping PHP cartridge
remote: [Thu Nov 21 02:26:00 2013] [warn] PassEnv variable SHELL was undefined
remote: [Thu Nov 21 02:26:00 2013] [warn] PassEnv variable USER was undefined
remote: [Thu Nov 21 02:26:00 2013] [warn] PassEnv variable LOGNAME was undefined
remote: Waiting for stop to finish
remote: Operation not permitted - /var/lib/openshift/528db435e55e7539ba0000be/app-deployments/by-id/32a86648
To ssh://528db435e55e7539ba0000be@cphp01-ccy.dev.rhcloud.com/~/git/cphp01.git/
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'ssh://528db435e55e7539ba0000be@cphp01-ccy.dev.rhcloud.com/~/git/cphp01.git/'

Expected results:
Building application after deploying by artifact_url should be successfully.

Additional info:
It will not meet this issue when deploying the binary file from local.
Comment 2 Luke Meyer 2013-12-23 11:10:08 EST
*** Bug 1033766 has been marked as a duplicate of this bug. ***
Comment 3 Luke Meyer 2013-12-23 11:19:49 EST
jdetiber already picked from upstream and built in errata puddle.

origin-server commit:
commit ae08e4ea393437954385922a1b0af13c2fe11805
Author: Andy Goldstein <andy.goldstein@gmail.com>
Date:   Thu Nov 21 09:46:34 2013 -0500

    Bug 1032950
    
    Change ownership of by-id link to gear uid/gid so future deployments
    that don't go through mcollective don't fail because of file
    permissions issues.


enterprise-2.0:
commit 478f3629ac8f81203ce3fc4913349942774ca7e1
Author:     Andy Goldstein <andy.goldstein@gmail.com>
AuthorDate: Thu Nov 21 09:46:34 2013 -0500
Commit:     Jason DeTiberus <jdetiber@redhat.com>
CommitDate: Thu Dec 5 16:08:51 2013 -0500
Comment 4 Gaoyun Pei 2013-12-24 03:43:07 EST
Verify this bug with rubygem-openshift-origin-node-1.17.5-3

After deploying the app by artifact_url, the app still could be deployed by git push successfully.
Comment 6 errata-xmlrpc 2014-01-13 09:54:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0020.html

Note You need to log in before you can comment on or make changes to this bug.