Bug 1033377 - Kernel module asix.ko is missing in initrd.img on dvd but needed for installation of
Summary: Kernel module asix.ko is missing in initrd.img on dvd but needed for installa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-22 00:57 UTC by Edgar Hoch
Modified: 2014-04-06 02:36 UTC (History)
6 users (show)

Fixed In Version: dracut-037-10.git20140402.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-06 02:36:52 UTC


Attachments (Terms of Use)

Description Edgar Hoch 2013-11-22 00:57:07 UTC
Description of problem:
Some weeks ago I have to install a notebook Lenovo ThinkPad X1 Carbon (3460-CLG).
Installation with Fedora 19 was not possible using pxe other the network because the network port was not enabled. I found that the driver for the network device is missing in the initrd.img of the Fedora 19 DVD (./images/pxeboot/initrd.img). I found that the driver is asix.ko and it is contained in the kernel rpm kernel-3.9.5-301.fc19.x86_64.rpm as ./lib/modules/3.9.5-301.fc19.x86_64/kernel/drivers/net/usb/asix.ko .

For Fedora 19 I have helped myself and unpacked initrd.img to the disc, extracted asix.ko from the rpm and build a new initrd.img . When using this new initrd.img in the pxe boot the kernel initialized the network device and uses dhcp to configure it.

I need the network device during installation because I use pxe and kickstart and remote repos and kickstart post scripts which need to access other servers during the installation.

I have forgotten to write a bug report for Fedora 19. Now I checked Fedora 20 TC2 and found that the module asix.ko is still missing in the initrd.img.

Please could you include the module asix.ko in the initrd.img of Fedora 20?

The module is contained in Packages/k/kernel-3.11.8-300.fc20.x86_64.rpm as ./lib/modules/3.11.8-300.fc20.x86_64/kernel/drivers/net/usb/asix.ko . It is missing in ./images/pxeboot/initrd.img on the Fedora 20-TC2 iso image.


Version-Release number of selected component (if applicable):
https://dl.fedoraproject.org/pub/alt/stage/20-TC2/Fedora/x86_64/iso/Fedora-20-TC2-x86_64-DVD.iso
Packages/k/kernel-3.11.8-300.fc20.x86_64.rpm
./images/pxeboot/initrd.img

How reproducible:
Always

Additional info:
I don't know which component belongs to the initrd.img file on the fedora dvd. I choose anaconda because it is the installation script, but I assume that this is not appropriate for initrd.img. Please change it to the right component. Thanks!

Comment 1 Brian Lane 2014-01-28 22:57:57 UTC
dracut handles creation of the initrd. FWIW it is present in the stage2 image so if you boot from cd or usb you should be fine.

Comment 3 Fedora Update System 2014-04-02 08:56:44 UTC
dracut-037-10.git20140402.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dracut-037-10.git20140402.fc20

Comment 4 Fedora Update System 2014-04-03 04:02:57 UTC
Package dracut-037-10.git20140402.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-037-10.git20140402.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4704/dracut-037-10.git20140402.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-04-06 02:36:52 UTC
dracut-037-10.git20140402.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.