Bug 103339 - putdate fails. Error: certificate verify failed
putdate fails. Error: certificate verify failed
Status: CLOSED DUPLICATE of bug 103336
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-28 21:06 EDT by Francesco Amelio
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francesco Amelio 2003-08-28 21:06:14 EDT
Description of problem:
When i run:
up2date -u
i see the following output:
There was an SSL error: [('SSL 
routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]

If i execute: 
openssl s_client -connect xmlrpc.rhn.redhat.com:443 -CAfile /usr/share/rhn/RHNS-
CA-CERT

The last line give:
Verify return code: 10 (Certificate has expired)

My system date is good but in /usr/share/rhn/RHNS-CA-CERT i see the expire date 
as follow:
Validity
Not Before: Aug 23 22:45:55 2000 GMT
Not After : Aug 28 22:45:55 2003 GMT

I think that all systems has this certificate date.

What's going on?

-----------------------------

Version-Release number of up2date component:
v3.0.7.1

How reproducible:
Always

Steps to Reproduce:
1.up2date -u
2.
3.
Comment 1 Bill Nottingham 2003-08-29 01:14:10 EDT

*** This bug has been marked as a duplicate of 103336 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.