Bug 103340 - up2date fails. Error: certificate verify failed
Summary: up2date fails. Error: certificate verify failed
Status: CLOSED DUPLICATE of bug 103336
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-29 01:06 UTC by Francesco Amelio
Modified: 2007-04-18 16:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Francesco Amelio 2003-08-29 01:06:28 UTC
Description of problem:
When i run:
up2date -u
i see the following output:
There was an SSL error: [('SSL 
routines', 'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]

If i execute: 
openssl s_client -connect xmlrpc.rhn.redhat.com:443 -CAfile /usr/share/rhn/RHNS-
CA-CERT

The last line give:
Verify return code: 10 (Certificate has expired)

My system date is good but in /usr/share/rhn/RHNS-CA-CERT i see the expire date 
as follow:
Validity
Not Before: Aug 23 22:45:55 2000 GMT
Not After : Aug 28 22:45:55 2003 GMT

I think that all systems has this certificate date.

What's going on?

-----------------------------

Version-Release number of up2date component:
v3.0.7.1

How reproducible:
Always

Steps to Reproduce:
1.up2date -u
2.
3.

Comment 1 Bill Nottingham 2003-08-29 05:14:20 UTC

*** This bug has been marked as a duplicate of 103336 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.