Bug 103366 - recent smartmontools support devices behind 3ware controllers
Summary: recent smartmontools support devices behind 3ware controllers
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-29 13:19 UTC by KELEMEN Péter
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 09:18:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description KELEMEN Péter 2003-08-29 13:19:27 UTC
Description of problem:
Recent versions of smartmontools support S.M.A.R.T. queries to IDE devices
behind 3ware controllers.  It would be very nice in enterprise environments
to have such version shipped with RedHat.

Comment 1 Arjan van de Ven 2003-08-29 13:32:54 UTC
Since this is an enterprise request, changing component to the enterprise linux beta

Comment 2 Bruce Allen 2003-09-05 13:12:56 UTC
Redhat: Don't forget that to fully support smartmontools on3ware controllers you
need to either:
  - use version 1.02.00.037 or greater of the 3w-xxxx driver, or
  - patch earlier 3ware 3w-xxxx drivers
Patch is here: http://smartmontools.sourceforge.net/3w-xxxx.txt

Comment 3 Arjan van de Ven 2003-10-09 09:18:31 UTC
this came in too late to bump the driver and redo QA...

Comment 4 Bruce Allen 2003-10-09 15:14:15 UTC
FYI the patch has been submitted as 3ware driver update for 2.6.0-test5-bk11.
See URL below. Adam tells me that it will make it into the 2.4 kernel tree very
soon now.

http://groups.google.com/groups?q=3ware+smartmontools+scsi&hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=linux.scsi.20030923162402.6ee8114d.akpm%40osdl.org&rnum=1


Note You need to log in before you can comment on or make changes to this bug.