Bug 103373 - Package names of new-SSL-certificate up2date RPMs do not upgrade via rpm
Summary: Package names of new-SSL-certificate up2date RPMs do not upgrade via rpm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: RHN Stable
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-29 14:33 UTC by Glen A. Foster
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-26 17:38:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glen A. Foster 2003-08-29 14:33:09 UTC
Description of problem: Due to the SSL certifiate expiring, Red Hat was kind
enough to provide updated RPMs for up2date and up2date-gnome that give a new
certificate, so operations can continue with/to RHN.  The solution fails to work.

Unfortunately, the filenames chosen:

    up2date-2[1].8.46.3-1.2.1AS.ia64.rpm
    up2date-gnome-2[1].8.46.3-1.2.1AS.ia64.rpm

... do NOT upgrade via "rpm -Uvh".  The rpm command simply exits with an exit
status of 0.  BUT, If one renames them to the same names without the brackets:

    up2date-2.8.46.3-1.2.1AS.ia64.rpm
    up2date-gnome-2.8.46.3-1.2.1AS.ia64.rpm

... THEN rpm -Uvh WILL upgrade the existing up2date and up2date-gnome packages.

Comment 1 Adrian Likins 2003-08-29 23:03:39 UTC
looks like a web bug , apparently fixed already

Comment 2 Glen A. Foster 2003-12-26 17:38:14 UTC
Doesn't happen anymore, assuming it really was fixed.


Note You need to log in before you can comment on or make changes to this bug.